Question & Answer
Question
Procedures to install, uninstall or upgrade GSKit V7 for Tivoli Directory Server on Windows server systems.
Cause
GSKit V7 provided with different versions of Tivoli Directory server needs to be upgraded as part of periodic preventive maintenance.
Answer
This document provides install, uninstall and upgrade instructions for GSKit V7 on Tivoli Directory Server supported Windows server systems.
Refer Recommended Fixes to find the latest recommended level of GSKit for a given version of Tivoli Directory Server.
Directory Server provided GSKit V7 latest fix levels are now available on Fix Central for entitled customers. Download GSKit V7 (7.0.4.35 or later fix levels) from Fix Central.
Also refer to GSKit V7- Instructions to find current installed version details.
AIX | HP-UX | Linux | Solaris | Windows |
Windows 32 bit
Windows x64 - 64 bit GSKit
Windows x64 - 32 bit GSKit
Windows - 32 bit |
Windows 32 bit - 32 bit GSKit - Install / Upgrade Instructions
Windows 32 bit - 32 bit GSKit - Uninstall Instructions
Windows 32 bit - 32 bit GSKit - Install / Upgrade Instructions:
Use Administrator login for the following procedure.
Its very important to download the appropriate packages as per your system platform. There are separate packages available for 32 bit as well as 64 bit Windows(x64).
a. Download the required level of GSKit V7.
a.i. If you have downloaded the GSKit V7 latest fix levels from Fix central the file name will be similar to "7.0.4.41-TIV-GSKIT-Win32-FP0041.zip". Transfer the file over to the target Windows system. Extract the file on Windows system:
- C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:28 AM <DIR> .
07/16/2012 10:28 AM <DIR> ..
07/16/2012 10:28 AM 5,339,549 7.0.4.41-TIV-GSKIT-Win32-FP0041.zip
After unzipping / extracing the zip file:
C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:44 AM <DIR> .
07/16/2012 10:44 AM <DIR> ..
05/22/2012 11:03 AM <DIR> 7.0.4.41-TIV-GSKIT-Win32-FP0041
07/16/2012 10:28 AM 5,339,549 7.0.4.41-TIV-GSKIT-Win32-FP0041.zip
C:\Temp\gsk>cd 7.0.4.41-TIV-GSKIT-Win32-FP0041
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-Win32-FP0041>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk\7.0.4.41-TIV-GSKIT-Win32-FP0041
05/22/2012 11:03 AM <DIR> .
05/22/2012 11:03 AM <DIR> ..
05/16/2012 12:19 PM 97 DATA.TAG
05/16/2012 12:19 PM 4,779,070 DATA1.CAB
05/16/2012 12:19 PM 7,948 DATA1.HDR
01/12/1999 10:34 AM 23,541 LANG.DAT
05/16/2012 12:19 PM 590 LAYOUT.BIN
07/27/1998 05:41 PM 450 OS.DAT
01/12/1999 11:42 AM 73,728 SETUP.EXE
05/16/2012 12:19 PM 95 SETUP.INI
05/03/2005 05:35 PM 68,465 SETUP.INS
06/29/2004 02:36 PM 332 SETUP.ISS
05/16/2012 12:19 PM 49 SETUP.LID
02/23/1999 10:45 AM 296,674 _INST32I.EX_
10/27/1998 12:06 PM 27,648 _ISDEL.EXE
09/29/1998 04:34 PM 34,816 _SETUP.DLL
05/16/2012 12:19 PM 175,466 _SYS1.CAB
05/16/2012 12:19 PM 3,948 _SYS1.HDR
05/16/2012 12:19 PM 1,265 _USER1.CAB
05/16/2012 12:19 PM 4,411 _USER1.HDR
18 File(s) 5,498,593 bytes
Now directly go to Step b. below.
a.ii. If you have downloaded a fix level prior to 7.0.4.35 from gskit download site, then you will have file such as gsk7bas.exe and transfer the file over to Windows system. Keep these files in a new folder (e.g.: c:\Temp\gsk704.28\).
- Open a command window as Administrator.
C:\temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is 8805-603D
Directory of C:\temp\gsk704.28
08/11/2010 11:52 AM <DIR> .
08/11/2010 11:52 AM <DIR> ..
08/11/2010 11:52 AM 5,949,741 gsk7bas.exe
1 File(s) 5,949,741 bytes
Important Note: To install on Windows 2008 server, the package, gsk7bas.exe must be first unpacked on an 32 bit Windows 2003 (or lesser OS). This is because the package, gsk7bas.exe is a 16-bit package and Windows 2008 does not have the 16-bit subsystem. Packages downloaded from Fix central contains the unpacked files. Hence the step below is not applicable for packages downloaded from Fix central.
Extract the exe file (note the dot/period in the command below which denotes current working directory as the folder to extract the package):
C:\temp\gsk704.28> gsk7bas.exe .
C:\temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is 8805-603D
Directory of C:\temp\gsk704.28
08/11/2010 11:58 AM <DIR> .
08/11/2010 11:58 AM <DIR> ..
02/05/2010 05:18 PM 97 DATA.TAG
02/05/2010 05:18 PM 4,742,414 DATA1.CAB
02/05/2010 05:18 PM 7,948 DATA1.HDR
08/11/2010 11:52 AM 5,949,741 gsk7bas.exe
01/12/1999 11:34 AM 23,541 LANG.DAT
02/05/2010 05:18 PM 590 LAYOUT.BIN
07/27/1998 05:41 PM 450 OS.DAT
01/12/1999 12:42 PM 73,728 SETUP.EXE
02/05/2010 05:18 PM 95 SETUP.INI
05/03/2005 05:35 PM 68,465 SETUP.INS
06/29/2004 02:36 PM 332 SETUP.ISS
02/05/2010 05:18 PM 49 SETUP.LID
02/23/1999 11:45 AM 296,674 _INST32I.EX_
10/27/1998 01:06 PM 27,648 _ISDEL.EXE
09/29/1998 04:34 PM 34,816 _SETUP.DLL
02/05/2010 05:18 PM 175,466 _SYS1.CAB
02/05/2010 05:18 PM 3,948 _SYS1.HDR
02/05/2010 05:18 PM 1,266 _USER1.CAB
02/05/2010 05:18 PM 4,411 _USER1.HDR
19 File(s) 11,411,679 bytes
b. Stop Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other processes such as TAM related services/processes which use gskit.
c. Install using setup.exe from the same command window as Administrator:
- C:\Temp\gsk\7.0.4.41-TIV-GSKIT-Win32-FP0041>SETUP.EXE LDAP
OR
C:\temp\gsk704.28> SETUP.EXE LDAP
The following install panel shows up.
- Click on Next button. The following install panel shows up.
- - Select appropriate destination folder by choosing Browse option (in case if you would like to customize the install location of GSKit).
- In case of Upgrade scenario - the Upgraded gskit will be installed into the same location as that of the initial GSKit install. If you need to choose a different location, then you must uninstall and then install into new install location.
- Click on Next button. The following install panel shows up after successful installation.
- - Click on Finish.
d. Verify the installed package levels:
- C:\temp\gsk704.28> reg query HKLM\SOFTWARE\IBM\GSK7\CurrentVersion /s
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion
Version REG_SZ 7.0.4.41
InstallPath REG_SZ C:\Program Files\ibm\gsk7
LibPath REG_SZ C:\Program Files\ibm\gsk7\lib
BinPath REG_SZ C:\Program Files\ibm\gsk7\bin
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion\REGAPPS
LDAP REG_SZ Registered
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion\Uninstall
UninstallFile REG_SZ C:\Program Files\ibm\gsk7\gsk7BUI.isu
UninstallExe REG_SZ C:\WINDOWS\gsk7BUI.exe
e. Start Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other services/processes such as TAM related processes which use gskit.
Return to top of page
Windows 32 bit - 32 bit GSKit - Uninstall Instructions:
Use Administrator login for the following procedure.
a. Stop Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other services/processes such as TAM related processes which use gskit.
b. Find the UninstallExe and REGAPPS:
- Open a command window as Administrator
C:\temp\gsk704.28> reg query HKLM\SOFTWARE\IBM\GSK7\CurrentVersion /s
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion
Version REG_SZ 7.0.4.41
InstallPath REG_SZ C:\Program Files\ibm\gsk7
LibPath REG_SZ C:\Program Files\ibm\gsk7\lib
BinPath REG_SZ C:\Program Files\ibm\gsk7\bin
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion\REGAPPS
LDAP REG_SZ Registered
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion\Uninstall
UninstallFile REG_SZ C:\Program Files\ibm\gsk7\gsk7BUI.isu
UninstallExe REG_SZ C:\WINDOWS\gsk7BUI.exe
c. Uninstall using one of the methods below:
- Using the same command window as administrator:
Syntax: <UninstallExe> <RegisteredApp>
In current case:
C:\> C:\WINDOWS\gsk7BUI.exe LDAP
Notes:
The Registered App is "LDAP" in this case from the output of b.
If you have more than one RegisteredApp then repeat the command below one at a time:
C:\WINDOWS\gsk7BUI.exe <RegisteredApp>
- In some old fix levels of GSKit v7 the following procedure works.
Syntax: <UninstallExe> -f <UninstallFile>
In current case:
C:\> C:\WINDOWS\gsk7BUI.exe -f "C:\Program Files\ibm\gsk7\gsk7BUI.isu"
- Manual Uninstall/Removal of GSKit: (Use this only if both the above mentioned methods fail)
- Delete the "InstallPath" folder:
- C:\> rmdir /S /Q "C:\Program Files\ibm\gsk7"
- Delete the registry:
C:\> reg delete HKLM\SOFTWARE\IBM\GSK7
Permanently delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7 (Yes/No)? Yes
The operation completed successfully.
d. Verify the Registry and Folders:
- C:\> reg query HKLM\SOFTWARE\IBM\GSK7\CurrentVersion /s
ERROR: The system was unable to find the specified registry key or value.
C:\> dir "C:\Program Files\ibm\gsk7"
Volume in drive C has no label.
Volume Serial Number is 8805-603D
Directory of C:\Program Files\ibm
File Not Found
Return to top of page
Windows x64 - 64 bit GSKit |
Windows x64 - 64 bit GSKit - Install Instructions
Windows x64 - 64 bit GSKit - Uninstall Instructions
Windows x64 - 64 bit GSKit - Upgrade Instructions
Windows x64 - 64 bit GSKit - Install Instructions:
Use Administrator login for the following procedure.
a. Download the required level of GSKit V7.
a.i. If you have downloaded the GSKit V7 latest fix levels from Fix central the file name will be similar to "7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip". Transfer the file over to the target Windows system. Extract the file on Windows system:
C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:44 AM <DIR> .
07/16/2012 10:44 AM <DIR> ..
07/16/2012 10:28 AM 9,924,495 7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip
After unzipping / extracing the zip file:
C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:59 AM <DIR> .
07/16/2012 10:59 AM <DIR> ..
05/22/2012 10:51 AM <DIR> 7.0.4.41-TIV-GSKIT-WinX64-FP0041
07/16/2012 10:28 AM 9,924,495 7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip
C:\Temp\gsk>cd 7.0.4.41-TIV-GSKIT-WinX64-FP0041
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041
05/22/2012 10:51 AM <DIR> .
05/22/2012 10:51 AM <DIR> ..
05/22/2012 11:06 AM <DIR> 32
05/22/2012 10:51 AM <DIR> 64
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041>cd 64
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041\64>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041\64
05/22/2012 10:51 AM <DIR> .
05/22/2012 10:51 AM <DIR> ..
05/15/2012 06:01 PM 5,155,840 GSK7BAS_64.msi
a.ii. If you have downloaded a fix level prior to 7.0.4.35 from gskit download site, then you will have file such as gsk7bas.zip and transfer the file over to Windows system. Keep these files in a new folder (e.g.: c:\Temp\gsk704.28\).
- Open a command window as Administrator.
C:\Temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is C498-AD18
Directory of C:\Temp\gsk704.28
08/13/2010 05:08 PM <DIR> .
08/13/2010 05:08 PM <DIR> ..
08/13/2010 03:19 PM 4,321,320 gsk7bas.zip
1 File(s) 4,321,320 bytes
Right Click on the gsk7bas.zip file and select "Extract All...". Click on the Next button in the Wizard. Choose the folder to be "C:\Temp\gsk704.28". Then click the Finish button to extract the GSK7BAS_64.msi file into the same folder.
C:\Temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is C498-AD18
Directory of C:\Temp\gsk704.28
08/13/2010 05:25 PM <DIR> .
08/13/2010 05:25 PM <DIR> ..
08/13/2010 03:19 PM 4,321,320 gsk7bas.zip
02/05/2010 02:29 PM 4,890,112 GSK7BAS_64.msi
2 File(s) 9,211,432 bytes
b. If you run into installation error with 64 bit GSKit on Windows x64 Servers - refer to this technote:
c. Run GSK7BAS_64.msi from Windows explorer by double click or from the command window:
Click on Next button. The following install panel shows up:
- Optional step: To customize the install Destination Folder Click on Change... button.
- Click on Next button. The following install panel shows up:
Click Install button. The following install panel shows up after successful installation:
Click Finish button.
- C:\temp\gsk704.28> reg query HKLM\SOFTWARE\IBM\GSK7\CurrentVersion /s
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\GSK7\CurrentVersion
InstallPath REG_SZ C:\Program Files\IBM\GSK7_64\
Version REG_SZ 7.0.4.41
LibPath REG_SZ C:\Program Files\IBM\GSK7_64\lib64
BinPath REG_SZ C:\Program Files\IBM\GSK7_64\bin
e. Start Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other services/processes such as TAM related processes which use gskit.
Return to top of page
Windows x64 - 64 bit GSKit - Uninstall Instructions:
Use Administrator login for the following procedure.
a. Stop Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other services/processes such as TAM related processes which use gskit.
b. Uninstall using one of the methods below:
- Windows Start -> Control Panel -> Add/Remove Programs -> GSK7BAS_64
Click on "Remove" button.
Click on Yes button.
c. Verify the Registry and Folders:
- C:\> reg query HKLM\SOFTWARE\IBM\GSK7\CurrentVersion /s
ERROR: The system was unable to find the specified registry key or value.
C:\> dir "c:\Program Files\IBM\GSK7_64"
Volume in drive C has no label.
Volume Serial Number is C498-AD18
Directory of c:\Program Files\IBM\GSK7_64
08/13/2010 05:39 PM <DIR> .
08/13/2010 05:39 PM <DIR> ..
08/13/2010 05:39 PM <DIR> classes
08/13/2010 05:39 PM <DIR> icc
Clean up Folders to remove any contents left behind after uninstall:
C:\> rmdir /S /Q "C:\Program Files\IBM\GSK7_64\"
C:\> dir "C:\Program Files\IBM\GSK7_64\"
The system cannot find the file specified.
Return to top of page
Windows x64 - 64 bit GSKit - Upgrade Instructions:
a. Follow 64 bit GSKit - Uninstall Instructions.
b. Then follow 64 bit GSKit - Install Instructions.
Return to top of page
Windows x64 - 32 bit GSKit |
Windows x64 - 32 bit GSKit - Install / Upgrade Instructions
Windows x64 - 32 bit GSKit - Uninstall Instructions
Windows x64 - 32 bit GSKit - Install / Upgrade Instructions:
Use Administrator login for the following procedure.
a. Download the required level of GSKit V7.
a.i. If you have downloaded the GSKit V7 latest fix levels from Fix central the file name will be similar to "7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip". Transfer the file over to the target Windows system. Extract the file on Windows system:
- C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:44 AM <DIR> .
07/16/2012 10:44 AM <DIR> ..
07/16/2012 10:28 AM 9,924,495 7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip
After unzipping / extracing the zip file:
C:\Temp\gsk>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk
07/16/2012 10:59 AM <DIR> .
07/16/2012 10:59 AM <DIR> ..
05/22/2012 10:51 AM <DIR> 7.0.4.41-TIV-GSKIT-WinX64-FP0041
07/16/2012 10:28 AM 9,924,495 7.0.4.41-TIV-GSKIT-WinX64-FP0041.zip
C:\Temp\gsk>cd 7.0.4.41-TIV-GSKIT-WinX64-FP0041
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041
05/22/2012 10:51 AM <DIR> .
05/22/2012 10:51 AM <DIR> ..
05/22/2012 11:06 AM <DIR> 32
05/22/2012 10:51 AM <DIR> 64
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041>cd 32
C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041\32>dir
Volume in drive C has no label.
Volume Serial Number is 2E47-65DB
Directory of C:\Temp\gsk\7.0.4.41-TIV-GSKIT-WinX64-FP0041\32
05/22/2012 11:06 AM <DIR> .
05/22/2012 11:06 AM <DIR> ..
05/22/2012 11:06 AM 97 DATA.TAG
05/22/2012 11:06 AM 4,779,070 DATA1.CAB
05/22/2012 11:06 AM 7,948 DATA1.HDR
05/22/2012 11:06 AM 23,541 LANG.DAT
05/22/2012 11:06 AM 590 LAYOUT.BIN
05/22/2012 11:06 AM 450 OS.DAT
05/22/2012 11:06 AM 73,728 SETUP.EXE
05/22/2012 11:06 AM 95 SETUP.INI
05/22/2012 11:06 AM 68,465 SETUP.INS
05/22/2012 11:06 AM 332 SETUP.ISS
05/22/2012 11:06 AM 49 SETUP.LID
05/22/2012 11:06 AM 296,674 _INST32I.EX_
05/22/2012 11:06 AM 27,648 _ISDEL.EXE
05/22/2012 11:06 AM 34,816 _SETUP.DLL
05/22/2012 11:06 AM 175,466 _SYS1.CAB
05/22/2012 11:06 AM 3,948 _SYS1.HDR
05/22/2012 11:06 AM 1,265 _USER1.CAB
05/22/2012 11:06 AM 4,411 _USER1.HDR
18 File(s) 5,498,593 bytes
Now directly go to Step b. below.
a.ii. If you have downloaded a fix level prior to 7.0.4.35 from gskit download site, then you will have file such as gsk7bas.exe and transfer the file over to a 32 bit Windows 2003 (or lesser ) system. Keep these files in a new folder (e.g.: c:\Temp\gsk704.28\).
- Open a command window as Administrator.
C:\temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is 8805-603D
Directory of C:\temp\gsk704.28
08/11/2010 11:52 AM <DIR> .
08/11/2010 11:52 AM <DIR> ..
08/11/2010 11:52 AM 5,949,741 gsk7bas.exe
1 File(s) 5,949,741 bytes
Important Note: To install 32 bit GSKit on a 64 bit Windows server, the package, gsk7bas.exe must be first unpacked/extracted on an 32 bit Windows 2003 (or lesser OS). This is because the package, gsk7bas.exe is a 16-bit package and 64 bit Windows does not have the 16-bit subsystem. Packages downloaded from Fix central contains the unpacked files. Hence the step below is not applicable for packages downloaded from Fix central. If the gsk7bas.exe gets run on a 64 bit Windows server the following error is shown:
Extract the exe file (note the dot/period in the command below which denotes current working directory as the folder to extract the package):
C:\temp\gsk704.28> gsk7bas.exe .
C:\temp\gsk704.28> dir
Volume in drive C has no label.
Volume Serial Number is 8805-603D
Directory of C:\temp\gsk704.28
08/11/2010 11:58 AM <DIR> .
08/11/2010 11:58 AM <DIR> ..
02/05/2010 05:18 PM 97 DATA.TAG
02/05/2010 05:18 PM 4,742,414 DATA1.CAB
02/05/2010 05:18 PM 7,948 DATA1.HDR
08/11/2010 11:52 AM 5,949,741 gsk7bas.exe
01/12/1999 11:34 AM 23,541 LANG.DAT
02/05/2010 05:18 PM 590 LAYOUT.BIN
07/27/1998 05:41 PM 450 OS.DAT
01/12/1999 12:42 PM 73,728 SETUP.EXE
02/05/2010 05:18 PM 95 SETUP.INI
05/03/2005 05:35 PM 68,465 SETUP.INS
06/29/2004 02:36 PM 332 SETUP.ISS
02/05/2010 05:18 PM 49 SETUP.LID
02/23/1999 11:45 AM 296,674 _INST32I.EX_
10/27/1998 01:06 PM 27,648 _ISDEL.EXE
09/29/1998 04:34 PM 34,816 _SETUP.DLL
02/05/2010 05:18 PM 175,466 _SYS1.CAB
02/05/2010 05:18 PM 3,948 _SYS1.HDR
02/05/2010 05:18 PM 1,266 _USER1.CAB
02/05/2010 05:18 PM 4,411 _USER1.HDR
19 File(s) 11,411,679 bytes
Now transfer the extracted folder from 32 bit Windows system onto 64 bit Windows system.
C:\Temp\gsk704.28>dir
Volume in drive C has no label.
Volume Serial Number is C498-AD18
Directory of C:\Temp\gsk704.28
08/16/2010 04:15 PM <DIR> .
08/16/2010 04:15 PM <DIR> ..
02/05/2010 05:18 PM 97 DATA.TAG
02/05/2010 05:18 PM 4,742,414 DATA1.CAB
02/05/2010 05:18 PM 7,948 DATA1.HDR
08/11/2010 11:52 AM 5,949,741 gsk7bas.exe
01/12/1999 11:34 AM 23,541 LANG.DAT
02/05/2010 05:18 PM 590 LAYOUT.BIN
07/27/1998 05:41 PM 450 OS.DAT
01/12/1999 12:42 PM 73,728 SETUP.EXE
02/05/2010 05:18 PM 95 SETUP.INI
05/03/2005 05:35 PM 68,465 SETUP.INS
06/29/2004 02:36 PM 332 SETUP.ISS
02/05/2010 05:18 PM 49 SETUP.LID
02/23/1999 11:45 AM 296,674 _INST32I.EX_
10/27/1998 01:06 PM 27,648 _ISDEL.EXE
09/29/1998 04:34 PM 34,816 _SETUP.DLL
02/05/2010 05:18 PM 175,466 _SYS1.CAB
02/05/2010 05:18 PM 3,948 _SYS1.HDR
02/05/2010 05:18 PM 1,266 _USER1.CAB
02/05/2010 05:18 PM 4,411 _USER1.HDR
19 File(s) 11,411,679 bytes
C:\temp\gsk704.28> SETUP.EXE LDAP
The following install panel shows up.
- Click on Next button. The following install panel shows up.
- Select appropriate destination folder by choosing Browse option (in case if you would like to customize the install location of GSKit).
- In case of Upgrade scenario - the Upgraded gskit will be installed into the same location as that of the initial GSKit install. If you need to choose a different location, then you must uninstall and then install into new install location.
- Click on Next button. The following install panel shows up after successful installation.
- Click on Finish.
c. Verify the installed package levels:
- C:\Temp\gsk704.28>reg query HKLM\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion /s
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion
Version REG_SZ 7.0.4.41
InstallPath REG_SZ C:\Program Files (x86)\ibm\gsk7
LibPath REG_SZ C:\Program Files (x86)\ibm\gsk7\lib
BinPath REG_SZ C:\Program Files (x86)\ibm\gsk7\bin
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion\REGAPPS
LDAP REG_SZ Registered
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion\Uninstall
UninstallFile REG_SZ C:\Program Files (x86)\ibm\gsk7\gsk7BUI.isu
UninstallExe REG_SZ C:\WINDOWS\gsk7BUI.exe
Return to top of page
Windows x64 - 32 bit GSKit - Uninstall Instructions:
Use Administrator login for the following procedure.
a. Stop Tivoli Directory Server related services/processes (ibmdiradm and ibmslapd) and any other services/processes such as TAM related processes which use gskit.
b. Find the UninstallExe and REGAPPS:
- Open a command window as Administrator
C:\> reg query HKLM\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion /s
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion
Version REG_SZ 7.0.4.41
InstallPath REG_SZ C:\Program Files (x86)\ibm\gsk7
LibPath REG_SZ C:\Program Files (x86)\ibm\gsk7\lib
BinPath REG_SZ C:\Program Files (x86)\ibm\gsk7\bin
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion\REGAPPS
LDAP REG_SZ Registered
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion\Uninstall
UninstallFile REG_SZ C:\Program Files (x86)\ibm\gsk7\gsk7BUI.isu
UninstallExe REG_SZ C:\WINDOWS\gsk7BUI.exe
c. Uninstall using one of the methods below:
- Using the same command window as administrator:
Syntax: <UninstallExe> <RegisteredApp>
In current case:
C:\> C:\WINDOWS\gsk7BUI.exe LDAP
Notes:
The Registered App is "LDAP" in this case from the output of b.
If you have more than one RegisteredApp then repeat the command below one at a time:
C:\WINDOWS\gsk7BUI.exe <RegisteredApp>
- In some old fix levels of GSKit v7 the following procedure works.
Syntax: <UninstallExe> -f <UninstallFile>
In current case:
C:\> C:\WINDOWS\gsk7BUI.exe -f "C:\Program Files (x86)\ibm\gsk7\gsk7BUI.isu"
- Manual Uninstall/Removal of GSKit: (Use this only if both the above mentioned methods fail)
- Delete the "InstallPath" folder:
C:\> rmdir /S /Q "C:\Program Files (x86)\ibm\gsk7"
- Delete the registry:
C:\> reg delete HKLM\SOFTWARE\Wow6432Node\IBM\GSK7
- Permanently delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IBM\GSK7 (Yes/No)? Yes
The operation completed successfully.
d. Verify the Registry and Folders:
- C:\> reg query HKLM\SOFTWARE\Wow6432Node\IBM\GSK7\CurrentVersion /s
ERROR: The system was unable to find the specified registry key or value.
C:\> dir "C:\Program Files (x86)\ibm\gsk7"
The system cannot find the file specified.
Return to top of page
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21443732