IBM Support

The LaunchPad utility displays a message stating that the LaunchPad is not intended to run on the current platform, or that it is not supported

Question & Answer


Question

The LaunchPad utility displays a message stating that the LaunchPad is "not intended to run on the current platform", or that it is not supported. How do I address this issue?

Cause

The LaunchPad utility utilizes the web browser already installed on the operating system in order to display text, graphics, and buttons. The LaunchPad is compatible with certain browsers, such as Mozilla Firefox and Microsoft Internet Explorer.

Web browsers can be configured with a great deal of flexibility. Also, browsers are often updated with new features and security fixes. For these reasons, the LaunchPad utility does not necessarily work for all systems that the WebSphere Application Server product is supported on. As browsers evolve, the LaunchPad may become incompatible with newer versions of browsers.

You must have a graphical user interface available on your operating system in order to use the LaunchPad.

The purpose of LaunchPad is to provide a convenient menu with buttons for starting the product's install program, and links to the product Information Center. If LaunchPad fails to start, it can be easily bypassed. You do not need the LaunchPad to run WebSphere Application Server product installers.

Answer

The LaunchPad utility is separate and distinct from the installer program for WebSphere Application Server. The WebSphere Application Server installer works in many situations where the LaunchPad utility does not. So, when the LaunchPad utility fails, the best course of action is to bypass it, and invoke the product installer directly. This will achieve the same purpose as the LaunchPad was intended for.

To bypass the LaunchPad and invoke a product installer directly, navigate to the product's subdirectory in the install media, and run the "install" program from that directory. For example, if you wanted to install WebSphere Application Server, navigate to the "WAS" subdirectory on the main install media disc, and run the "install" program from that directory.

The table below provides hints about where the product installer directories are located for V6.1 and V7.0.


Product Name
Name of directoryInstall media disc title
WebSphere Application ServerWASMain product disc
IBM HTTP ServerIHSSupplemental disc
WebSphere PluginpluginSupplemental disc
WebSphere Application ClientAppClientSupplemental disc

The LaunchPad is a part of the original installation media, and therefore it is not patched or updated like the WebSphere Application Server product is updated. If you find that LaunchPad does not work on your operating system, then use the bypass method above to activate the installer.

Note that if a graphical user interface is not available in your operating system, then you will need to run the product installer in silent mode. For specific details, please use the product's Information Center, and browse the topic related to product installation.

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Document Information

Modified date:
23 June 2018

UID

swg21413358