Troubleshooting
Problem
When you start a business-level application that uses a Service Component Architecture (SCA) composite, an XMLSchemaException exception might occur and prevent the application from starting.
Symptom
When you start the SCA application, it fails with an exception stack trace that resembles the following text:
org.apache.ws.commons.schema.XmlSchemaException:
Schema name conflict in collection.
Namespace: namespace_URL
at org.apache.ws.commons.schema.SchemaBuilder.
handleXmlSchemaElement(SchemaBuilder.java:223)
at org.apache.ws.commons.schema.SchemaBuilder.
build(SchemaBuilder.java:202)
at org.apache.ws.commons.schema.XmlSchemaCollection.
read(XmlSchemaCollection.java:424)
at org.apache.ws.commons.schema.XmlSchemaCollection.
read(XmlSchemaCollection.java:347)
at org.apache.ws.commons.schema.XmlSchemaCollection.
read(XmlSchemaCollection.java:379)
Cause
This problem, which involves a timing issue, might occur in SCA applications that have any of the following conditions:
- WSDL or XSD definitions are imported from another (shared) contribution.
- More than one deployable composite is packaged within a single asset Java™ archive (JAR) file. The composites are added to more than one business-level application, but not all if the deployable composites in the single asset are added to a single business-level application.
Resolving The Problem
If you encounter this problem, start the business-level applications separately by completing the following steps:
- Start the application server and see which business-level applications fail to fully start.
- Stop each business-level application that failed to start (either stopped or partially started).
- Start each remaining business-level application, one at a time.
Another fix is to configure the server to start on a single thread.
Related Information
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Document Information
Modified date:
06 June 2019
UID
swg21410810