IBM Support

Unable to open Rich Client on Web Server: Failed to find Java VM

Troubleshooting


Problem

Unable to open the Rich Client on Web Server. It opens up successfully on the Application Server and Client Machines.

Symptom

The following error is displayed when trying to open the Rich Client on the Web Server:

"cognosrcp.exe - Unable to Locate Component. This application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix this problem."

"Startup Error. Failed to find Java VM."

Cause

Known Defect. Contact IBM Customer Support for further details if required.

Environment

Distributed Environment

Resolving The Problem

Ensure that the PATH Variable is pointing to a directory containing the MVCR71.dll file.

If no Path Variable is set on the Web Server then adding a directory which contains the file should fix the problem. Since there are several instances of this DLL file within different folders, the best way to check which directory to point to, is to determine what the Path Variable is set to on the Application Server.

[{"Product":{"code":"SS9S5U","label":"Cognos 8 Planning"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Contributor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
23 June 2018

UID

swg21409510