Troubleshooting
Problem
The 'Update Index' and 'Regenerate Index' radio buttons are missing from the search tab in the Rational Change Admin interface.
Cause
This can occur if the URL in the search.lock file is different than the Rational Change installation URL.
This could happen if there was something as simple as a protocol change to the URL from http or https.
The search.lock URL is incorrect causing the issue.
Environment
Rational Change installations
Diagnosing The Problem
The buttons will be missing where normally visible.
Resolving The Problem
- For Change prior to version 5.3 the search.lock file is located in:
<RC_HOME>/jetty/webapps/change/WEB-INF/wsconfig/system
This file can be removed or manually edited to include the correct URL information for the Rational Change server. After the change to the file is made, navigate to another tab and then back to the search tab and the buttons will now display.
- In version 5.3 the search.lock file was moved to:
<RC_HOME>\jetty\webapps\change\WEB-INF\wsconfig\search
The same process applies for the search.lock file.
[{"Product":{"code":"SSYQQ2","label":"Rational Change"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.2;5.2.0.1;5.2.0.2;5.2.0.3;5.2.0.4;5.2.0.5;5.2.0.6;5.2.0.7;5.3;5.3.0.1;5.3.0.2","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
23 June 2018
UID
swg21408867