IBM Support

IBM Security Guardium: Predefined reports "Test Detail Exception" and "Test Exception" are empty on Managed units

Question & Answer


Question

Why predefined reports "Test Detail Exception" and "Test Exception" are empty on Managed units?

Cause

VA test exceptions are stored on CM whether they are generated from CM or MU.

Answer

VA test exceptions are stored on CM whether they are generated from CM or MU. Hence Predefined reports "Test Detail Exception" and "Test Exception" will bring results on CM only and will be empty on Managed units.
Workflow:
1. VA test can be run from CM or MU.
2. "Add Test Exception" button adds exception to an internal test exceptions table on CM whether it is generated from CM or MU
3. When predefined reports e.g. "Test Exception" run on MU, they look in an internal table on MU only and will be blank because data is only on CM
There is no mechanism for MU GUI interactive report to get data from CM table
 
4. When predefined reports e.g. "Test Exception" run on CM, they look in an internal table on CM and bring results
5. You can run grdapi commands on MU or CM to view results from CM table
Grdapi commands:
  • "grdapi list_test_exception"
  • "grdapi list_test_detail_exception"

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Component":"","Platform":[{"code":"PF004","label":"Appliance"}],"Version":"10.x,11.0,11.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Product Synonym

IBM Guardium

Document Information

Modified date:
10 March 2020

UID

ibm11275034