IBM Support

Drill through from PDF to PDF or PDF to HTML not working

Troubleshooting


Problem

Attempting to drill through from report run in PDF format is failing with an error.

Symptom

Attempting to drill through from report run in PDF format is failing with an error "Can't reach this page". It might also display a pop-up error from Adobe "An error occurred during the submit process. There was a problem connecting to the server".

Cause

Incorrect gateway URL or Adobe settings to control the behavior of accessing PDFs over the internet are incorrect.

Resolving The Problem

Steps:

1. Ensure the Cognos gateway URL is referencing the gateway (if one is being used) and not the dispatcher.
Example: http://<webserver name>:<web server port>/ibmcognos/bi/v1/disp
2. Change Adobe settings to modify the behavior for accessing the Internet from PDFs
a. In Acrobat DC or Acrobat Reader DC, choose Edit > Preferences (Windows) or Acrobat / Acrobat Reader > Preferences
b. From the Categories on the left, select Trust Manager.
c. Click Change Settings to specify the default behavior for accessing the Internet from PDFs.
d. To allow access to all URLs, select Allow PDF Files To Access All Web Sites

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
03 November 2021

UID

ibm11274026