Question & Answer
Question
Message priority levels can be set to instruct the JMS provider to deliver urgent messages first.
Sterling Order Management as consumer -
The application will pick messages from the queue in the order provided by the queue.The JMS provider will use the priority to provide messages to OMS in the order of priority, OMS will honor it.
The application will pick messages from the queue in the order provided by the queue.The JMS provider will use the priority to provide messages to OMS in the order of priority, OMS will honor it.
How can the priortiy for messages be set with Sterling Order Management as producer?
Cause
As a part of the out-of-box service definition framework (SDF), the application only supports setting string properties to a message using the "Header" tab of JMS producer from SDF.
The application does not allow setting any other type of property or header apart from string property.
Answer
This can be achieved in a two step process-
1. A queue can be set up into which the messages can be dropped , this will have the header properties/string properties that can be set from the out of box SDF.
2. A custom agent implementation can then be set up to read messages from this queue and add all the required properties on the message (like priority) and drop the message to the vendor owned destination queue.
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"v9.5,v10, OMoC","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
31 December 2019
UID
ibm11165942