Troubleshooting
Problem
PowerPlay client gives a PDS-RM-0002 error when opening a remote cube. The Cognos portal will be displayed but when the cube is selected in the portal it will not open and display the error.
Opening remote cubes on the PowerPlay client that is directly installed on the server site will work.
Symptom
PDS-RM-0002 The PowerPlay server is not available
Cause
Problem with the network connection.
Resolving The Problem
Navigate to: IBM Cognos Administration -> PowerPlay Tab-> Cube Settings and change the following settings:
- Queued request timeout (s) (3600)
- Connection timeout (min) (60)
- Request timeout (s) (3600)
- Idle process timeout (min) (60)
- Queued request timeout (s) (3600)
- Connection timeout (min) (60)
- Request timeout (s) (3600)
- Idle process timeout (min) (60)
Navigate to: IBM Cognos Administration -> PowerPlay Tab-> Report Settings and change the following settings:
- Queued request timeout (s) (3600)
- Connection timeout (min) (60)
- Request timeout (s) (3600)
- Idle process timeout (min) (60)
- Queued request timeout (s) (3600)
- Connection timeout (min) (60)
- Request timeout (s) (3600)
- Idle process timeout (min) (60)
Navigate to : IBM Cognos Administration -> Status -> System -> All Servers (dropdown) -> Services(dropdown) -> PowerPlay -> PowerPlayService(dropdown) -> Set Properties -> Settings Tab -> Advanced settings(edit)
and add the following parameters with values:
SRV.Options.MaxRestrictClientConnections (Value=IN,50)
SRV.Options.RestrictClientTimeout (Value=IN,60)
and add the following parameters with values:
SRV.Options.MaxRestrictClientConnections (Value=IN,50)
SRV.Options.RestrictClientTimeout (Value=IN,60)
Increase the idle time out value in the powerplayservice.xml file to a value large enough for the report to complete running.
<child-proc-cmd>idleTimeLimitSec=3600</child-proc-cmd>
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"PowerPlay Client;PowerPlay Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.x;11.1.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
20 November 2019
UID
ibm11109733