IBM Support

DPR-ERR-2109 The dispatcher cannot service the request at this time. The dispatcher is still initializing. Contact your administrator if this problem persists.

Question & Answer


Question

Why Common reporting is not opening and giving the error DPR-ERR-2109. The dispatcher cannot service the request now. The dispatcher is still initializing. Contact your administrator if this problem persists. 

Cause

This solution only relates to those cases where this message appears in the cogserver.log:

CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. Cause: CM-CFG-5137 Content Manager was unable to complete the initialization of the content store. For more information, review the log file. Before you restart Content Manager, you may need to re-create the content store database or clean it using dbClean_*.sql.

Answer

To resolve this content store issue, you must follow the steps

Manual modifications on the Content Store database are not supported. Take a backup of the Content Store.

Running the following sql against the Content Store database solves.

DELETE FROM .[dbo].[CMSYSPROPS] where PROPNAME ='dbInitMeta_mssqlserver.sql+1'

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

TS002337647

Document Information

Modified date:
09 November 2020

UID

ibm11108383