Troubleshooting
Problem
User launches Controller classic client. User launches any JAVA-based menu item, for example:
- "Group - Command Center"
- "Maintain - Sytem Audit Log - Configuration"
An error appears.
Symptom
The exact error will vary, for example:
However it will include the following phrase:
Caused by: com.sun.xml.internal.ws.client.ClientTransportException: The server sent HTTP status code 401: Unauthorized
Cause
There are several known causes:
- Scenario #1 - Controller application server's IIS website has been configured so that the 'controllerserver' (CCRWS.ASMX) website is using Windows authentication
- In some environments this will trigger the error
- For more details, see separate IBM Technote #959431
- Scenario #2 - Controller application server's IIS website is configured to not allow the provider "NTLM"
- In some environments this will trigger the error
- Scenario #3 - Defect (APAR PH19793) in some later versions of Controller.
- For more details, see separate IBM Technote #1119885
Resolving The Problem
Scenario #1
Reconfigure the Controller-related IIS portion to use anonymous authentication.
- TIP: For more details, see separate IBM Technote #959431.
Scenario #2
In some environments, it is necessary to enable NTLM.
- TIP: For more details, see separate IBM Technote #237157.
Scenario #3
Fix: Upgrade to a future version of Controller.
Workaround: Reconfigure the Controller-related IIS portion to use anonymous authentication.
- TIP: For more details, see separate IBM Technote #1119885.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
04 December 2019
UID
ibm11107495