IBM Support

CNC-SDS-0408 There are email messages waiting to be sent.

Troubleshooting


Problem

Emails go into waiting status with error CNC-SDS-0408.
There are email messages waiting to be sent.

Symptom

Emails are not being sent out.

Cause

The server is trying to authenticate to the mail server and the mail server doesn't support authentication.

Diagnosing The Problem

Enable SDS trace.
Logs will show the following errors in cogserver.log file: 
  
2019-11-14T15:12:40.411-0500    INFO    Audit.RTUsage.DLS    [SMTPQueueConsumerManager]                NA                                     TransportConnectionPool : getTransport : 13 : MessagingException : javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client 
2019-11-14T15:12:40.411-0500    INFO    Audit.RTUsage.DLS    [SMTPQueueConsumerManager]                NA                                    <trace>CNC-DS-0001 The following Delivery Service general error occurred: No authentication mechanisms supported by both server and clientNo authentication mechanisms supported by both server and client</trace> 

Resolving The Problem

Remove the user ID and password from the SMTP mail server settings in Cognos Configuration. Save and restart services.
Ignore the "[ERROR] Access to default session denied" warning if it is displayed.  

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 November 2019

UID

ibm11107327