Troubleshooting
Problem
User performs a consolidation. An error occurs.
User performs a database optimise. An error occurs.
Symptom
Error when running consolidation:
The ODBC connection is missing or invalid
Error when running database optimisation:
Error occured when deleting temporary VFP files: ODBC Error (2)
Cause
There are many possible causes for the above messages.
- TIP: See separate IBM Technotes #384423 & 375487 for more examples.
This Technote specifically relates to the scenario where the cause is that the COM+ user (the username used to run the COM+ application) does not have sufficient rights to use the Oracle client.
Example:
In most customer environments, using the default COM+ settings (where the Identity Account is set to 'Local System Account') is OK (no problem):
However, in some environments, that user does not have enough permissions (to the Oracle client, for example the registry keys relating to Oracle).
Environment
This problem is rare (only affects a very small proportion of environments).
Resolving The Problem
In some (rare) environments, the COM+ user must be changed to be the application server's local Windows user 'administrator'.
- For example: servername\administrator
Steps:
1. Logon to the Controller application server
2. Launch Controller Configuration
3. Open section: COM+ Server
4. Modify the value of Identity Account to be: Specify Account
5. Change the value to be the application server's local Windows user 'administrator'.
- For example: servername\administrator
6. Save changes
7. Test.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
14 November 2019
UID
ibm11106979