IBM Support

Try to connect to Planning Analytics Workspace result into a "Proxy Error" in the browser window

Troubleshooting


Problem

Planning Analytics Workspace is up and running. It's possible to start and open the Planning Analytics Workspace Administration Tool. Validation is fine and the status shows all containers up and running. But when users try to access Planning Analytics Workspace in a web browser, the following error message occurs:

Proxy Error

Reason: DNS lookup failure for wa-proxy

Symptom

Unable to access Planning Analytics Workspace from any machines.
Planning Analytics Workspace is not accessible.

Cause

With the Docker installation, the Docker service provides its own Docker DNS Server that is listening on port 53.
The Docker DNS server holds all the container names and IP addresses.
This Docker DNS cannot be launched because another DNS Server service was installed and started up. The host DNS server service is listening on port 53 as well. It results in a port conflict.

Environment

Windows Server 2016
Planning Analytics Workspace
Docker

Diagnosing The Problem

Verify that a running container can find another container with a nslookup command:
docker exec -it pa-gateway nslookup wa-proxy
Or
docker exec -it pa-gateway nslookup redis
A successful result looks like this:
image-20191108115627-3
A failure caused by a Docker DNS issue looks like this:
image-20191108120523-5

Resolving The Problem

On the Windows host system, check whether there is a service called "DNS Server", and if it is started.
1. Open the "Services" dialog (from Windows start menu, search for "services.msc" and run it)
2. In this dialog, search for a service called "DNS Server"
3. If that service exists and is started, then get in contact with your System administrator.
This service needs to be stopped, because it's using the same communication port 53 as the Docker DNS server.
The issue is a port conflict which prevents the Docker DNS server from starting up.
It is possible that "DNS server" service comes from an installation of Active Directory Server. In that case, it is recommended to install Active Directory Server onto a dedicated machine instead.
If your system administrator agrees to stop "DNS Server", then follow the remaining steps:
4. Open a Powershell window (with right-click, "Run as Administrator")
5. Stop Planning Analytics Workspace: 
  <PAW>\scripts\paw.ps1 stop
6. Stop the Docker service: from Windows start menu, run "services.msc", search for a service called "Docker" or "Docker Engine". Select this entry and stop it by using the "Stop Service" button.
7. When stopped successfully, start the Docker service again: Select the "Docker" or "Docker Engine" entry and start it by using the "Start Service" button.
8. The start of the Docker Engine launches the Docker's embedded DNS server (not the "DNS Server" service), and Planning Analytics Workspace containers.
9. After few minutes, verify the container states:
  <PAW>\scripts\paw.ps1 ps
10. If some containers are not failing to start, then regenerate new ones with these commands:
<PAW>\scripts\paw.ps1 down
<PAW>\scripts\paw.ps1

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"Component":"Planning Analytics Workspace","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
09 January 2023

UID

ibm11104681