IBM Support

Non admin users cannot enter data in Planning analytics cube view - Cells appears to be locked.

Troubleshooting


Problem

Non ADMIN users should have write access to the dimension elements they are trying to update in the view but Only ADMIN users can enter data at this point.

 

Symptom

The problem can be seen in different Planning Analytics components:
  • In Planning analytics for Excel, user enters data and try to commit the value but that doesn't work since the cell appears to be "locked".
  • In Planning analytics workspace, user is unable to enter the data in the grayed out cell. 
  • In Architect, user cannot enter data as well however we see the following error message: Cell is not editabe: No Data Reservation

Cause

Data Reservation is enabled for the cube.

Environment

Planning Analytics 2.0.x.

Resolving The Problem

As an ADMIN:
  • Open up the }CubeProperties control cube.
  • Check if the "DataReservationMode" is set on the cube.
  • In our case, it was set to "REQUIREDSHARED" value.
  • Remove the "REQUIREDSHARED" value so Data reservation is disabled for the cube in question.
  • Refresh Security.
  • Users can log in and update cells as expected now.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
20 September 2021

UID

ibm11102491