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Hanging (slow / crashing) when using Controller, triggered by message appearing inside Window located offscreen, triggered by "Save Window Size" being enabled

Troubleshooting


Problem

User performs a task in Controller. This seems to hang/crash.
Specifically, the user clicks on a button, and expects to see a new Window appear (for example a message box). The window/message never appears.
User may now find that their session of Controller appears to hang - it is impossible for them to perform any task in Controller (click on any button/menu item).

Symptom

There are many different potential scenarios/symptoms.
  • See separate IBM Technotes #1672412, 1347666, 1619537, 1650480,  884838 for more examples.
Problem may appear intermittent under some circumstances.
  • For example, it may work OK when user's client PC is connected to an external monitor (to give 2 displays). However, it fails if the user does not plug in their laptop into an external monitor.
  • Alternatively, it may work OK when connected to one 'good' Citrix server

Cause

By default, the Controller client stores the position of the window screens inside the file 'ccr.config' (in their user profile).
  • See separate Technote #1347666 for more details.
If the user moves the relevant window (or message box) to a different screen (for example monitor #2) or a far corner of a large monitor, then (when later using only 1 screen, or a smaller monitor) the saved position may be on an invalid position on the screen. Therefore the end user cannot see the message/window, and so cannot acknowledge/action it
=> Therefore Controller appears to have hung.

Environment

Example:
For example, imagine a scenario (for example Controller-on-Cloud) where:
  • Controller client being delivered via Citrix
  • There are 2 Citrix servers
  • Each Citrix server has a separate Windows profile (no roaming profiles).
In the above scenario, the Windows positions are saved on separate Citrix servers (therefore separate Windows profiles)
=> Therefore the windows position may be visible (good) on Citrix server #1, bit invisible (bad) on Citrix server #2.

Resolving The Problem

Long-term Fix:
Modify the 'bad' end user's settings, so that it stops Controller from remembering screen positions
  • In other words, for this 'bad' user only (per user setting) Controller will no longer remember/save the location/size of Windows positions.

Steps:
Each individual user should do the following:
1. Click "Maintain / User / Personal Defaults > tab Layout (2)"
2. Untick the box 'Save Window Size':

3. Click Save
4. Logoff from Controller, and re-launch the Controller client.

===================================================
NOTE: The above 'Save Windows Size' change is stored inside the database, inside the 'xconfig' table. It is recorded separately for each individual user:

Therefore:
  • Each end user must make this change separately
  • They must repeat the change for each separate database that they use (for example 'production', 'test' and so on).
===================================================

Workarounds
There are several possible workarounds:
  • In some situations, the solution is to plug in the external (second) monitor (the same one that was used when this function was last run successfully).
  • Reset the values inside "CCR.config".

Document Location

Worldwide

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Document Information

Modified date:
12 October 2021

UID

ibm11078377