IBM Support

Automated Reporting is not working.

Troubleshooting


Problem

Management Automated Report stopped working,  Only modifications made to CC were for Out of memory issues and some fine tuning recommended by IBM support.

Symptom

Engine logs show errors
ERROR ControlCenterAgentRemoteOpWithRetryTask -
Stack Trace:
java.lang.NullPointerException
at com.sterlingcommerce.scc.client.proxy.ControlCenterAgentRemoteOpWithRetryTask.doWork(ControlCenterAgentRemoteOpWithRetryTask.java:62)
at com.sterlingcommerce.scc.client.proxy.ControlCenterAgentRemoteOpWithRetryTask.run(ControlCenterAgentRemoteOpWithRetryTask.java:214)
at java.lang.Thread.run(Thread.java:812)
[DefaultQuartzScheduler_Worker-8] ERROR ScheduledReportsJob - Unable to generate report output. Exception Msg :null
com.sterlingcommerce.scc.client.proxy.CCException

Cause

The scripts runEngine and runEngineCold had been modified to use -DBrowserAgent=false

Diagnosing The Problem

Look at Engine logs and runEngine and runEngineCold scripts

Resolving The Problem

Alter runEngine and runEngineCold scripts to use -DBrowserAgent=true

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"6.1.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

ibm11075521