IBM Support

Why is a CHARGE for refund not being opened when the option 'Create Refund Payment and Charge Request' is selected?

Troubleshooting


Problem

Consider the below scenario -
1. Gift card is a payment method of type SVC
2. This payment method allows refund to a new payment method  (EGIFT_CARD) and has this configuration enabled -
Create Refund Payment and Charge Request
3. The flag Allow refund to exceed charge amount is enabled.


When an order paid through SVC is returned and requestCollection is run on the sales order, a CHARGE for refund is not opened

Symptom

The charge transaction entry for RETURN moves to CHECKED status, however there is no CHARGE opened for the refund

Cause

This is due to the refund configuration for payment type - EGIFT_CARD
This has Refund to the same payment type enabled.

Diagnosing The Problem

The refund on a particular payment method type is governed by its refund configuration. 
As the configuration for EGIFT_CARD says refund to same payment method, the product is unable to refund to a newly created EGIFT_CARD .

Resolving The Problem

For EGIFT_CARD, the refund configuration should use "Create Refund Payment And Charge Request".
This can be set in SBC under System Setup > Payment Types

Document Location

Worldwide

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Document Information

Modified date:
01 November 2021

UID

ibm11074056