IBM Support

Information Server 11.5 and 11.7 Update Installer sometimes displays HTTP 500 error with NumberFormatException error in browser

Troubleshooting


Problem

On some Windows systems, using Update Installer 11.7.1.033 or later to apply a patch or fixpack in GUI mode leads to an HTTP 500 error window in the web browser with a NumberFormatException.

Symptom

The failure is intermittent. Sometimes it happens when the user clicks the "login" button in the startup panel, or when the "Next" button is used to move from one panel to the next. The most frequent occurrence is in the Microservices upgrade panel, when checking the checkbox to update the path to the Microservices repository. It has also been seen in the panel used to install a new Microservices tier, when scrolling the window with the scroll bar.
In all cases, the browser display of the Update Installer user interface is replaced by an HTTP 500 error window containing an error that looks like this:

Caused by:
java.lang.NumberFormatException: For input string: "50.400001525878906"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:76)
 

Cause

The cause of this failure is not fully understood. It is affected by the version of Windows, the browser used, and the browser version.

Environment

This failure is seen on Windows 10, but not on Windows 7.  It has not been seen on Linux or AIX, and it does not happen on every Windows 10 environment. 

The failure happens in some 64-bit browsers, but not all. It has not been seen in 32-bit browsers.

The failure appears to only happen when the browser is on the same Windows machine as the installer.  Connecting to the installer remotely appears not to cause the problem, even when the remote machine is running the same version of Windows as the installation machine, and the remote browser is the same brand and version as one that causes the problem when run on the installation machine.

On some occasions, the issue occurred while navigating to the MS Tier panel with browser zoom size set between 70% to 100%.

Diagnosing The Problem

The problem is diagnosed if, when running the Update Installer in GUI mode, an HTTP 500 window is displayed in the browser with an exception stack trace starting with a NumberFormatException and having stack frames starting with "org.eclipse.swt.internal" a few frames down:

java.lang.NumberFormatException: For input string: "50.400001525878906"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:76)
 

Resolving The Problem

There are several workarounds for this problem:
1. Connect to the Update Installer remotely. To do this, start the installUpdates.exe program from a Command or PowerShell window that has been launched with Administrator authority. When the default browser comes up, close it. Then use a browser running on a remote machine (any OS) to connect to the URL that the installUpdates.exe program printed to its console. For example:
 
C:\IBM\InformationServer\Updates\bin>installUpdates.exe
INFO: Patch Installation program will be running in this session, please do not close patch installation window until patch installation program completes.
The Update installation program started at 9/12/19 1:36 AM.

======> Enter the following URL to your web browser to begin the installation process:
https://hostname.hostdomain.com:8443/ISInstall
Then paste "https://hostname.hostdomain.com:8443/ISInstall" into the search field of the remote browser.

2. Reduce the browser zoom level to below 70% and refresh the browser to avoid the error.
    More often than not, changing the zoom level gets us past the exception.
3. Install a 32-bit version of Mozilla Firefox or Google Chrome on the Windows machine where the install is to be performed. Either temporarily make it the default browser, or run it by hand and use it to connect to the installUpdates.exe URL, as above.

4. Try a different brand of 64-bit browser on the installation machine. Sometimes Chrome will fail but FireFox or Internet Explorer/Edge might work.

5. If the problem happens when using a scroll bar in a Microservices tier panel, try navigating the panel with the TAB key instead of the scroll bar.
6. If the problem happens in one of the Microservices tier panels, try clicking the Next button without entering anything in the panel. If the NumberFormatException happens, try refreshing the browser and and then click the Back button. If a validation error window appears, it means the update installer is past the NumberFormatException. It should then be possible to enter the correct values into the fields of the Microservices tier panel and continue with the Next button.
 

Document Location

Worldwide

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Document Information

Modified date:
17 March 2021

UID

ibm11073784