IBM Support

New Cognos Analytics users receive error: Invalid login response

Troubleshooting


Problem

After an upgrade from Cognos BI 10.2.2 to Cognos Analytics 11.0.x, users that had not logged into Cognos BI 10.2.2 previously encounter error when logging into Cognos:

Invalid login response

Symptom

Users that had logged into Cognos BI 10.2.2 are able to log into the upgraded Cognos Analytics 11.  However if those users were moved to a new Organizational Unit (OU) in Active Directory they also encounter the "Invalid login response".

Cause

Users logging into Cognos Analytics appear to be authenticated successfully based on AAA traces captured but the Content Manager request for properties of the user account did not return any objects leading to the error.

Diagnosing The Problem

Performed a test by configuring Cognos Analytics to use a newly created empty SQL Server Content Store database and verified that this allowed new users to log in successfully.

Resolving The Problem

Create new Content Store database and import content via deployment.
Steps:
1. Export full Content Store deployment including user account information from the original Content Store database
2. Stop Cognos Analytics services
3. Create new Content Store database
4. Reconfigure Cognos Analytics to use the new Content Store database
5. Start Cognos Analytics services
6. Import full Content Store deployment from Step 1.
7. Log into Cognos Analytics as a System Administrator
8. Go to Cognos Administration, Security tab, Cognos namespace.
9. Go to System Administrator properties, Members tab
10. Confirm appropriate Group and\or Users are members of this Role and remove Everyone as a member.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Content Store","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
09 September 2019

UID

ibm11073266