Troubleshooting
Problem
If you configure the ethernet adapter while Load Balancer is running, problems occur.
Symptom
Various issues can occur:
- Requests not forwarded.
- Both Load Balancer's can go active in a high availability environment causing a duplicate IP error for the cluster address and forwarding issues.
- A system crash could occur.
Cause
The Load Balancer component of WebSphere Application Server attaches to the ethernet interface in order to receive and send packets with minimal performance impact. If you perform any adapter configuration, the Load Balancer's interface to the adapter is affected and packets are not sent or received by the Load Balancer.
Environment
Before any adapter configuration is performed, stop the Load Balancer's executor. Restart the executor after configuration is complete. Examples of functions that interfere with Load Balancer's operation include (but are not limited to): AIX® smit and cfgmgr, Microsoft® Adapter properties, Linux® ethtool, adapter failover, adapter teaming, or bonding.
Resolving The Problem
Ensure that the Load Balancer's executor is stopped before modification of adapter settings. With adapter teaming or bonding, ensure that adapter settings are not dynamically updated. Do not configure adapter failover, use the Load Balancer's high availability feature for adapter failures.
Document Location
Worldwide
[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Component":"Load Balancer","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF051","label":"Linux on IBM Z Systems"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Historical Number
1460115
Product Synonym
Load Balancer
Was this topic helpful?
Document Information
Modified date:
08 February 2020
UID
ibm11072320