Troubleshooting
Problem
Attempts to create an IBM Rational ClearCase Remote Client (CCRC) view result in java.lang.NullPointerException, "java.io.IOException:", "java.lang.NullPointerException".
Symptom
When you try to create a base, (non-UCM ClearCase view in CCRC, you see either of the following errors.
Error 1
[Problem Occurred]
X Create View (Time of error: December 5, 2008 3:00:05 PM CST)
Reason:
java.lang.NullPointerException
The details button also shows the following message.
An Internal error occurred in "Create View"
Error 2
Set View Configuration... Problems performing ClearCase operation.
Error: "java.io.IOException: "Error: "java.lang.NullPointerException: null" "
Operation terminated due to prior error."
"Error: "java.lang.NullPointerException: null" "
Operation terminated due to prior error.
Cause
Two reasons are known.
- The URL provided to access the CM Web Server is incorrect.
- Valid ClearCase licenses are unavailable.
Resolving The Problem
Enter the correct URL along with the correct port number (if necessary) to connect to the CM Server as in the example below.
Example:
- Non-working URL:
http://my-server/ccrc/TeamWeb/services/Team
- Working URL (updated to reflect the appropriate port number):
http://my-server:12080/TeamWeb/services/Team
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21330707