Troubleshooting
Problem
When you create a new Automation Document Processing automation project, creation fails. Expanding the technical details section shows:
"error": {
"errorId": "CIWCA13100",
"explanation": "There is no tenant database available.",
"action": "Please contact System Admin."
}
Cause
When a new project is created, the Automation Document Processing base database is queried to locate an available tenant (project) database. If all tenant databases are used, this error occurs.
Diagnosing The Problem
To get a list of the product databases and their status, run the ProjectList.sh script. See Managing Automation Document Processing Project Databases for more details.
Resolving The Problem
For Production deployments
- Create more project databases per step 4 in the instructions at Preparing the databases for Document Processing engine. Be sure to add the database names to the 'tenant_databases' section of the custom resource yaml and applying the yaml.
- Import the default data per the instructions at Loading default sample data.
- Update the aca-basedb secret with the name and password of the new databases per step 2 in the instructions at Creating secrets to protect sensitive Document Processing configuration data.
For Starter deployments
Starter deployments are restricted to two project databases, so new databases cannot be added. However, if the original databases are no longer needed, they can be reset following the technote Resetting Automation Document Processing project databases in Starter deployments.
Troubleshooting further
If you still cannot create new projects, then there is some other issue with getting the database information and the spbackend pod logs must be checked for details.
oc get pods |grep spbackend
oc logs <spbackend pod name> > <spbackend pod name>.log
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAKPAA2","label":"Operate-\u003EADP Install\\Upgrade\\Setup"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
26 October 2023
UID
ibm16552368