Troubleshooting
Problem
Symptom
When the searchCatalogIndex API input was run from the API tester, the item list is returned empty when run from API tester for nonworking items.
Error:
<Attribute Name="ErrorCode" Value="YCM85_016"/>
<Attribute Name="ErrorDescription" Value="Could not find active search index."/>
Catalog Index Build does not work for certain specific items and it throws an error.
Cause
Diagnosing The Problem
Resolving The Problem
https://www.ibm.com/docs/en/order-management?topic=transactions-create-catalog-index
The parameter Incremental Build needs to be set to Y to rebuild the existing index file. If you specify Y, Sterling Order Management rebuilds the index based on the last successful index build. The MaxModifyTS column in the YFS_ITEM table determines whether or not an item's attributes have changed. If any external attributes of an item have changed, update the MaxModifyTS column by calling the manageItem API on the item.
As the customer has incremental build on, the MaxModifyTs time in YFS_ITEM should be updated to the latest date for that item to be eligible to be picked during the catalog build.
The value for MaxModifyTS is updated to the latest time when an item is modified.
Document Location
Worldwide
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Document Information
Modified date:
27 December 2023
UID
ibm17012039