IBM Support

Netcool/OMNIbus 8.1 : Installing a test fix probe patch

Question & Answer


Question

imcl : Probe test fix package cannot be installed, what is the cause?

Cause


Installation Manager reports:

ERROR: Package Netcool/OMNIbus Probe nco-p-email is already installed in this package group.

when applying a test fix patch because the packages tend to be point releases, whilst GA packages are full releases.

It is therefore necessary to first remove the GA package, and then install the test fix patch.

Answer

Unlike the GA product packages for integrations software, the test fix patches can be point releases and appear as already installed, according to the installation manager.

In order to work around the installation manager behavior, the probe package being patch needs to be removed, and then the test fix patch applied.

Before installation, stop the probe, and any other probes that use the same supporting packages, as the package installation may cause the probe to hang or crash.

To use the IM uninstall option an X Display server is required, although this display is not used for user interaction.

  • Before you begin, set the DISPLAY environment variable to the X Display server
DISPLAY=<X-Server-IP-Address>:0.0
export DISPLAY

  • Check redisplay works, where possible
xterm
^C

  • Confirm that the package is installed, in this example the email probe
~/IBM/InstallationManager/eclipse/tools/imcl listInstalledPackages | grep email
com.ibm.tivoli.omnibus.integrations.nco-p-email_1.5.0.5

  • Stop the probe and any other related probes

  • Run IM with the uninstall option to remove the iinstalled probe package

~/IBM/InstallationManager/eclipse/tools/imcl uninstall com.ibm.tivoli.omnibus.integrations.nco-p-email
Uninstalled com.ibm.tivoli.omnibus.integrations.nco-p-email_1.5.0.5 from the /opt/nrv81/tivoli/netcool directory.

  • Confirm that the package was removed
~/IBM/InstallationManager/eclipse/tools/imcl listInstalledPackages | grep email
<nothing returned>

  • Install the test fix patch using the zip file provided by support
~/IBM/InstallationManager/eclipse/tools/imcl -c install
com.ibm.tivoli.omnibus.integrations.nco-p-email -repositories
./omnibus-probe-nco-p-email-1.5.4.0.zip

  • Confirm the package was installed successfully
~/IBM/InstallationManager/eclipse/tools/imcl listInstalledPackages | grep email
com.ibm.tivoli.omnibus.integrations.nco-p-email_1.5.4.0

  • Confirm the version details from the command line
$OMNIHOME/probes/nco_p_email -version


Note: To see what packages are available in the test fix patch file use:
~/IBM/InstallationManager/eclipse/tools/imcl listAvailablePackages -repositories

./omnibus-probe-nco-p-email-1.5.4.0.zip
com.ibm.tivoli.omnibus.integrations.nco-p-email_1.5.4.0


Remember to check if there are prerequisites, such as fix packs or supporting products such as the non-native probe.

Whenever possible install the latest fix pack and supporting packages as well as the test fix patch to ensure all issues are resolved.

[{"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"8.1.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21969097