Troubleshooting
Problem
NSE install fails and install log contains the following message: /opt/ibm/db2/V9.7/./adm/ctecsdem to /tmp/nsetempzmeDwj/./adm/ctecsdem failed. Invalid cross-device link
Symptom
Install fails and returns error message:
Error while trying to backup file "/opt/ibm/db2/V9.x/./adm/ctecsdem".
DB2 Net Search Extender Version 9.7.0.3 installation to /opt/ibm/db2/V9.x failed.
For details see /tmp/db2nseXXXXXXXXXXXXXXX.log.
Cause
An older version of NSE installed. NSE Fix Packs are complete product packages, therefore you will need to uninstall first , then install the new fix pack.
Diagnosing The Problem
Look for the following message:
/opt/ibm/db2/V9.7/./adm/ctecsdem to /tmp/nsetempzmeDwj/./adm/ctecsdemfailed. Invalid cross-device link
in the nse install log returned by the install error message.
Resolving The Problem
NSE Fix Packs are complete product packages, therefore you will need to uninstall first , then install the new fix pack.
To uninstall Net Search Extender on UNIX operating systems, stop the instances, and issue the db2nse_deinstall command.
Complete the following steps to uninstall Net Search Extender correctly on UNIX operating systems:
1. For each DB2 instance from which you want to uninstall Net Search Extender:
2. Switch to the user ID of the DB2 instance.
3. Stop the DB2 Net Search Extender instance.
4. Stop the DB2 instance.
5. Ensure that you are active as the root user.
6. Change your working directory to the DB2 path where you want to remove Net Search Extender. For example, cd /opt/IBM/db2/V9.7/install.
7. Issue the command ./db2nse_deinstall
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21512231