Troubleshooting
Problem
MustGather documents aid in problem determination and save time resolving Support cases. These documents contain a list of the documentation you should gather so DataPower Support can diagnose your specific problem. These documents might also include diagnostic tips that will aid in diagnosing and solving problems.
Cause
Collecting MustGather data early, even before opening the Support case, helps DataPower Support quickly determine if:
- Symptoms match known problems (rediscovery)
- There is a non-defect problem that can be identified and resolved
- There is a defect that identifies a workaround to reduce severity
- Locating root cause can speed development of a code fix
Resolving The Problem
► Gather the following information needed to entitle your case:
- Serial number of the appliance
- Firmware version
- Use the WebGUI Navigation Bar Status > System > Version Information
- IBM customer numbers
- A valid contact e-mail address and phone number
- Severity of this issue to your business
- Note: Set the severity of your problem based on the Severity Levels table found in WebSphere DataPower Warranty and Maintenance Support Services.
► Gather the following general problem information:
- A complete description of the problem, including the following:
- List of steps to recreate the behavior
- Capture images of the screen to help describe the steps
- Error messages
- Any changes to installed firmware version
- Exported Error Report- Instructions to collect WebGUI or CLI
-
- ► Determine and gather component specific information:
General MustGather documents Collecting data: IBM DataPower Gateway Appliance problem determination CLI MustGather documents Collecting data on the command line: IBM DataPower Gateway Appliance problem determination API Connect MustGather documents MustGather - Collecting data: IBM API Connect problem determination Service MustGather documents MustGather: Collecting data for problems with Multi-Protocol Gateway, Web Service Proxy, or XML Firewall on IBM DataPower Gateway Appliance Restart/Resource related MustGather documents Mustgather: Memory Growth for DataPower Firmware 2018.4.1+ MustGather: IBM DataPower Gateway Appliance statistics gathering File Transfer MustGather documents MustGather: Collecting data when experiencing FTP issues on IBM DataPower Gateway Appliances ITCAM MustGather documents MustGather: Documentation for ITCAM SOA and IBM DataPower Gateway problem determination Logging MustGather documents MustGather for IBM DataPower Gateway Appliances NFS Log Target MQ MustGather documents Collecting data: WebSphere MQ and IBM DataPower Gateway Appliances problem determination ODBC MustGather documents MustGather: Collecting data when experiencing ODBC issues on IBM DataPower Gateway Appliances SSL/TLS MustGather documents Mustgather: Collecting data for TLS problems on IBM DataPower Gateway Appliance WebGUI Performance MustGather documents MustGather for IBM DataPower Gateway Appliance WebGUI Performance issues WSProxy MustGather documents MustGather: Collecting data when experiencing issues with a Web Service Proxy on IBM DataPower Gateway Appliances - ► Determine and gather component specific information:
► Opening a DataPower Support Case
More information on opening Support Cases can be found at IBM Support page.
► Exchanging information with IBM Support
You can keep updated on your issues through the case at IBM Support. Also, you can upload data directly to the case. *Note: If you have additional questions, please visit Support Portal FAQ
You can keep updated on your issues through the case at IBM Support. Also, you can upload data directly to the case. *Note: If you have additional questions, please visit Support Portal FAQ
*General hints and tips*
- Search for known problems from the DataPower Gateway Support site.
- Download the latest firmware.
- Download and view product documentation.
- Receive weekly Support email: Sign up for My Notifications to receive a customized weekly email from IBM support. Learn about announcements and important technical support information.
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Document Information
Modified date:
07 December 2022
UID
swg21269260