Troubleshooting
Problem
This document will assist you in collecting the data necessary to diagnose and resolve IBM Rational Collaborative Lifecycle Management dashboard issues.
Cause
This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a PMR with IBM Support for further investigation providing the data collected.
Resolving The Problem
You can use the IBM Support Assistant Lite (ISA Lite) Data Collector tool to quickly collect diagnostic files, such as log files, configuration files or to run traces. This tool is bundled with RTC 4.x and above. ISA Lite collects information about your Jazz Team Server environment and stores the information in a .zip archive file. If you have a need to open a service request with IBM Support for further assistance, you can send the archive file with the data collection so that they can help diagnose and fix problems.
The information below should be gathered in addition to the normal information and log gathering done by ISA Lite.
Jazz Foundation and Dashboard Trace
General information |
- Verify if a server rename has occurred
For errors in the web UI which include 'null' |
- Enable ?debug=true in the browser and collect a screenshot of the full error
Example: https://<servername>:9443/jts/web/projects/Project?debug=true#action=....
Firebug Trace |
- If the issue is reproducible in the web UI, install Firebug in your Firefox browser. Add ?debug=true to the URL and reproduce the issue. Include a screenshot of the ‘console’ section of Firebug for any related errors
Jazz Foundation and Dashboard Trace |
In the log4j.properties (..server/jts/conf), add the following line for trace:
log4j.logger.com.ibm.team.dashboard.service.internal.jfs.HttpResourceClient=DEBUG
- Save the log4j.properties file.
- Reload the log4j.properties file by accessing the following link:
https://<server>:9443/jts/admin?internal=true#action=com.ibm.team.repository.admin.reloadLoggingSettings
(This will avoid having to restart the server)
- Reproduce the issue and provide the jts.log file
Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki. |
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Product Synonym
Rational Team Concert;Rational Quality Manager
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Document Information
Modified date:
29 September 2018
UID
swg21632563