Troubleshooting
Problem
This document will assist you in collecting the data necessary to diagnose and resolve process and work item customization issues you may be experiencing when using IBM Rational Team Concert (RTC).
Cause
This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a PMR with IBM Support for further investigation providing the data collected.
Resolving The Problem
You can use the IBM Support Assistant Lite (ISA Lite) Data Collector tool to quickly collect diagnostic files, such as log files, configuration files or to run traces. This tool is bundled with RTC 4.x and above. ISA Lite collects information about your Jazz Team Server environment and stores the information in a .zip archive file. If you have a need to open a service request with IBM Support for further assistance, you can send the archive file with the data collection so that they can help diagnose and fix problems.
The information below should be gathered in addition to the normal information and log gathering done by ISA Lite.
General information |
- Collect the running process template as per How to Extract a Process template from an existing project area
- Generate the Runtime report
- Identify which roles or users are incurring the bad behaviour
- Is this reproducible in the web UI and eclipse client?
- Screenshots of the error or bad behavior
For permissions related issues |
- Verify the settings at the Project Area level
- Verify the process customization at the Team Area level (TeamArea settings are overriding ProjectArea settings)
For errors in the web UI which include ‘null’ |
- Enable ?debug=true in the browser and collect a screenshot of the full error
Example:
https://<servername>:9443/ccm/web/projects/Project?debug=true#action=com.ibm.team.workitem.viewWorkItem&id=xxx
Firebug Trace |
- If the issue is reproducible in the web UI, install Firebug in your Mozilla Firefox browser. Add ?debug=true to the URL and reproduce the issue. Include a screenshot of the console tab.
- Install NetExport and export the output in the NET tab within Firebug
Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki. |
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Product Synonym
Rational Team Concert
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Document Information
Modified date:
29 September 2018
UID
swg21632449