IBM Support

Mustgather - IBM Business Automation Document Processing

Question & Answer


Question

What is the information that is to be collected and provided when you are requesting support assistance for IBM Business Automation Document Processing?

Cause

Automation Document Processing is deployed as part of IBM Cloud Pak for Business Automation (CP4BA).  This document provides guidance on information to collect and provide for issues specific to Automation Document Processing.

Answer

Index
  1. Collect for all issues
  2. If unable to run the script
  3. Pod reference
  4. What to do next

1. Collect for all issues
This section lists the basic information needed for all issues.
  • Download and run the adp_mustgather.sh script and upload the tar.gz file to the case.  If the issue is associated with a specific error, reproduce the error, note the time, then run the script immediately after you generate the error.
  • Platform - Specify the platform that is being used.  Red Hat, AWS, Azure, ROKS, and so on.
  • Red Hat OpenShift Version - Specify the version of Red Hat OpenShift the product is deployed on.
  • Cloud Pak deployment type - Specify whether the deployment type is a starter or production deployment along with any other relevant details of the deployment. 
  • Exact problem - This information can be a screen capture of the error or the file that contains the error.  Provide the complete file or listing, rather than just extracting the error.  Complete data allows Support to better understand the context under which the error occurred.
  • Exact repro steps - Provide the exact actions that lead to the problem to include buttons clicked and data entered. 
  • Scope - Did the issue start happening on a previously running system, or is it associated with a new deployment, upgrade, or configuration change of some kind?  Does it happen for all documents, users, or workstations, or is the issue specific to just one or a few documents, users, or workstations?

2. If unable to run the script
If you ran the adp_mustgather script, skip this section.  If you cannot run the script for security or other reasons, the information can be collected manually by using the commands in this section.  Most commands must be run within the deployment namespace either by first changing to that workspace, or by adding -n <namespace> to the command.
  • For user interface issues in a browser, collect the browser console information.  For Chrome, press F12, select the Console tab, reproduce the issue, and copy the generated contents.
  •  Collect OpenShift Container Platform version information
    oc version > version.txt
  • Collect node information.
    oc get nodes -o wide > nodes.txt
    kubectl top nodes > nodeusage.txt
  • Collect pod information.
    kubectl get pods > pods.txt
  • Collect routing information.
    oc get route > routes.txt
  •  Collect the defined secrets.
    oc get secrets > secrets.txt
  • Collect the storage information.
    oc get sc > storageclasses.txt
    oc get pv > pv.txt
    oc get pvc > pvcs.txt
  • Collect the description and log of any pod that you are having issues with.  See the Pod reference section for a list of pods.
    oc describe pod <pod-name> > <podname>.txt
    oc logs <podname> > <podname>.log
  • Operator deployment status - Provide the operator log.
    • If this issue is associated with a new deployment
      oc logs <ibm-cp4a-operator pod> > operator.log
    • If this issue is associated with an existing deployment, replace <namespace> and <local_logpath>.
      deployment_name=$(kubectl get icp4acluster | awk '{print $1}' | grep -v "NAME")
      operator_pod_name=$(oc get pod|grep ibm-cp4a-operator | awk '{print $1}')
      oc cp $operator_pod_name:/logs/$operator_pod_name/ansible-operator/runner/icp4a.ibm.com/v1/ICP4ACluster/<namespace>/$deployment_name/artifacts /<local_logpath>
  • Provide the Content Operator log.
    oc logs <ibm-content-operator pod> > contentoperator.log

3. Pod reference
Automation Document Processing is tightly integrated with a number of other components within CP4BA.  For questions regarding which pods might be associated with an issue, use this reference.  Some versions and deployments do not have all of these pods.
  • cdra-deploy - Content Designer resources
  • cds-deploy - Content Designer services
  • cpds-deploy - Content Designer deployment
  • bastudio-authoring, bastudio-deployment - BAStudio pages, application, toolkits, and templates
  • cpe-deploy - Content-processing-services event handlers
  • navigator-deploy - Runtime environment
  • pbk-ae-deployment - Runs the development environment applications
  • workspace-aae-ae-deployment - Runs the runtime environment applications
  • viewone-deploy - Daeja ViewONE viewer
  • cp4a-operator - CP4BA Multipattern Operator processing
  • content-operator - Content Operator processing
  • gitgateway-deploy - Communications with Git repositories
  • graphql-deploy - Handles Graphql calls
  • aca-cleanup-job-hourly - Detect and correct hung documents and processes
  • aca-cleanup-job-daily - Clean out old documents, logs, and other data
  • Document Processing Engine pods
    • spbackend - Base and project database communications along with document uploads
    • setup - Initial document conversion and page extraction
    • ocr-extraction, str-extraction, iocr-extraction - extracts text from document
    • classifyprocess-classify - document class classification
    • natural-language-extractor - Basic KVP extraction processing
    • processing-extraction - Advanced KVP extraction processing
    • postprocessing - completes document processing to build JSON output
    • deep-learning -  Performs extraction training
    • rabbitmq-ha, redis-ha-server - Internal document processing controllers
    • callerapi, updatefiledetail - Internal document processing functions (22.0.1 and older versions)

  1. Review the log files entries generated at the time of the problem to try to determine the cause.
  2. Check these locations for known issues:
  3. Once you complete gathering all the needed information and diagnostics, you can add them to your case or upload files to ECURep.  More information on ECURep is available at Enhanced Customer Data Repository (ECuRep) - Overview.

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Document Information

Modified date:
06 February 2024

UID

ibm16434299