Troubleshooting
Problem
Multiple XQE folders over 100 GB are generated in the ../logs/XQE directory.
Symptom
Cognos Analytics is encountering instability and unexpected failures due to lack of local hard diskspace.
Cause
Query planning trace and query execution trace can be enabled in the dispatcher settings and query service settings resulting in excessive and unnecessary logging to be written to the Cognos Analytics logs.
Resolving The Problem
Query planning and execution traces are only used for diagnosing specific issue in isolated tests in a nonproduction environment. Do not use these logging settings for prolonged periods of time and do not use them in a production environment because they can impact performance and stability.
Check the dispatcher and query service logging settings and disable options for query planning and query execution traces and disable them.
Steps:
1. Go to Administration console in the browser.
2. Click System on the Status tab.
3. Click the server name then click the down arrow and select Set properties for the dispatcher.
4. Click the Settings tab, set Category drop[down to Logging.
5. Disable the options for Enable query execution trace and Enable query planning trace. Click Ok
7. Click the dispatcher link. Click the down arrow for QueryService and select Set properties.
8. Click the Settings tab
10. Disable the options for Enable query execution trace and Enable query planning trace. Click Ok
8. Restart the environment
Document Location
Worldwide
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Document Information
Modified date:
23 February 2023
UID
ibm10884298