Troubleshooting
Problem
I.T. administrator opens up Event Viewer on the SQL Server, and opens the 'Application log'. There are multiple entries referring to login failures.
Symptom
Event Log title - SQL 2005:
Failure Audit <date> <time> MSSQLSERVER (4) 18456 N/A <SERVERNAME>
Event Log details - SQL 2005:
Event Type: Failure Audit
Event Source: MSSQL$SQL2005
Event Category: (4)
Event ID: 18456
Date: 27/11/2007
Time: 09:28:32
User: N/A
Computer: SERVERNAME
Description:
Login failed for user 'sa'. [CLIENT: 142.88.130.93]
Cause
Something is attempting to connect to the SQL server with the wrong password for the 'sa' user account, *and* the SQL server's security audit settings are configured to log failure events.
- Example #1:
- Example #2:
Resolving The Problem
Check both of the following, to ensure that the correct username/password are being used:
- The 'application repository' database connection(s)
- and the 'Data Mart' database connection(s)
Then get a short period of downtime, and restart the Controller Batch Server service.
Steps:
1. Logon to the Controller Application server
2. Launch Controller Configuration from the start menu
3. Check the settings inside the 'Database Connections' section
4. Check the settings inside the 'Database connections for publish to data mart' section
5. Obtain a short period of downtime
6. Restart the 'Cognos Controller Batch Server' Windows service.
Historical Number
1037381
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Document Information
Modified date:
15 June 2018
UID
swg21347518