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Maximo Visual Inspection - Engine Deploy Error

Troubleshooting


Problem

Users receive the following error when running inspections:
 
engine deploy error
{"result": "fail","'fault":"Engine [ID]-interactive already exists\n"}

Cause

This error indicates that an interactive inspection has not been deleted for the inspection. Interactive inspections are created when the Review inspection button is clicked in an Inspection configuration. Once in the Review inspection page, the user should always click the Back button to exit the Review inspection page. This ensures that the corresponding interactive inspection is properly deleted. There is apparently some (as yet unidentified) user behavior that exits the Review inspection page but does not delete the interactive inspection. When this happens, the interactive inspection that was initially created does not get deleted, and the next time Review inspection is clicked, the system tries to create an interactive inspection. However, since it was not deleted, the error is thrown.

Resolving The Problem

The way to get out of this state is to:

  • Clear the interactive inspections out of the database using the command:
    docker exec -it vision-edge-controller psql -c "delete from pipelines where inspection_uuid like '%interactive'"
  • Then restart edge using the restartedge.sh script.
  • Once that is done, the problem should be resolved.

Document Location

Worldwide

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Document Information

Modified date:
09 April 2024

UID

ibm17147616