Troubleshooting
Problem
Symptom
Cause
Login as the mobile user from browser. Open a new browser tab and check the user profile by using the API query:
https://api.MAS_URL/profile?workspaceId=workspace_ID
The workspace is blank. It indicates that the user does not belong to any workspace.
Mobile user needs to belong to a workspace with access to applications e.g. Manage, assist, monitor
Diagnosing The Problem
- Resetting the app does not help.
- No error in the debug device log and coreapi logs.
- Mobile user can view data from role-based applications and other Manage applications.
- New users could access applications in the Maximo Mobile app.
But old users that exist prior to the upgrade could not access applications in the Maximo Mobile app.
- Check the Admin workspace in MAS (Maximo Application Suite). Select Users in the left panel.
Select a mobile user. The application access section is blank. Mobile user no longer has access to applications after MAS upgrade.
Check the application access for other users. Old users do not have access to applications.
Only new users have application access and all the applications display on the mobile device.
Resolving The Problem
Document Location
Worldwide
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Document Information
Modified date:
10 January 2024
UID
ibm17106758