IBM Support

Maximo Mobile for Application Suite not downloading

Troubleshooting


Problem

After successfully logging in to Maximo Mobile for Maximo Application Suite, the Navigator icons appear as read only and the application don't download.

Symptom

Once logged in the applications, they are not able to be selected.

Cause

The reason for this, is once logged in the application then calls to the Maximo Application Suite api to determine the applications to download.  If the resources don't exist, the modules do not download to the application.

Diagnosing The Problem

The request to determine the application happens on the core api pod. When the log is reviewed, you can see an error similar to the following.
2022-01-24 14:40:45,882   managers.mobile                 INFO     Could not make request to https://maximosupport.svc/maximo/api/graphite/mobile/packages?workspaceId=maximo&userid=maxadmin for packages list: ConnectionError(MaxRetryError("HTTPSConnectionPool(host='maximosupport.svc', port=443): Max retries exceeded with url: /maximo/api/graphite/mobile/packages?workspaceId=demo&userid=maxadmin (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7f446c454d30>: Failed to establish a new connection: [Errno -2] No address found'))"))
2022-01-24 14:40:45,883   exceptions                      DEBUG    MASException:80259b83-8454-4f6b-9c91-3628cc8658d3 has been created for AIUCO1004E: The requested resource could not be found.

Resolving The Problem

The reason this error occurs is likely due to the mobile server bundle not being deployed. To deploy the server bundle, follow these steps.
1. Log in to the Maximo Application Suite admin
2. Select Manage 
3. Update Configuration
4 Where it says Mobile (Optional) set it to the bundle name you want mobile deployed to.
image-20220628110010-1

Document Location

Worldwide

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Document Information

Modified date:
13 June 2023

UID

ibm16550874