Troubleshooting
Problem
The Maximo EAR fails to deploy and an OutOfMemory is thrown during EJB deployment.
Symptom
Unable to complete EAR deployment process to bring up Maximo.
Cause
This is caused when the EJB deployment exceeds it's maximum default heap size of 256MB
Resolving The Problem
If your Maximo deployment runs out of memory during the EJB deployment portion, you may need to increase the heap size from 256MB to 512MB. To do this follow the steps below.
1. Edit the ejbdeploy.bat located in \ibm\WebSphere\AppServer\deploytool\itp\
2. Search for the following section.
if "%EJBDEPLOY_JVM_HEAP%"=="" ( set EJBDEPLOY_JVM_HEAP=-Xms256m -Xmx256m
) else ( echo "using JVM heap %EJBDEPLOY_JVM_HEAP%" )
3. Change the -Xmx to 512m and save the file so the section now looks like
if "%EJBDEPLOY_JVM_HEAP%"=="" ( set EJBDEPLOY_JVM_HEAP=-Xms256m -Xmx512m
) else ( echo "using JVM heap %EJBDEPLOY_JVM_HEAP%" )
Now attempt your Maximo ear deployment again.
[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"System Related","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
17 June 2018
UID
swg21902890