IBM Support

The Maximo Application Suite setup process does not complete due to misconfigured internal Behavior Analytics Services URL

Troubleshooting


Problem

During Maximo Application Suite initial setup, if the Behavioral Analytics Services URL does not include the port number, the setup process indicates success but does not complete.
If you chose to use the internal Behavioral Analytics Service URL, you must include the port number at the end of the URL:  
https://servicename.projectname.svc:8443

Symptom

The Maximo Application Suite setup process does not complete.

Cause

The Behavioral Analytics Service URL is incorrectly formatted.

Diagnosing The Problem

After you install Maximo Application Suite, access the Setup page at:
admin.masdomain/initialsetup
Check the URL that appears under System scoped configuration for Behavior Analytics to see whether it ends with the characters '.svc' like this:
https://servicename.projectname.svc:8443
If it has this form but does not include a port number, the Setup page indicates a successful registration of the Behavior Analytics Services endpoint and lets the user proceed to finalize the setup.
 The setup goes into a loop and does not complete.

Resolving The Problem

If you are using an internal intra-cluster URL for the Behavior Analytics Services URL, it must include the port number and must be of the form:  
https://servicename.projectname.svc:8443
There are two ways to fix the misconfiguration. 
Using the Maximo Application Suite administration page

From the Administration page:
  1. Select Configurations.
  2. Click Behavioral Analytics Service.
  3. Click the pencil icon to edit the configuration.
  4. In the URL field, add the port number following the format specified earlier. 
Important: You must enter the API Key to save the configuration. 
Scroll down and click Save to apply the changes.  A success notification appears on the right top side.
Using the OpenShift Cluster administration
From the Overview console in the OpenShift Cluster:
  1. Open the Administration section on the left side menu.
  2. Click Custom Resource Definition.
  3. In the search box type BasCfg
  4. Click Instances.
  5. In the search box type the instance-name that you provided during the Maximo Application Suite installation.
  6. Click the resource found.
    Example: instance_name-bas-system
  7. Select the YAML tab.
  8. Add the port number to the url that is located under spec.config
    spec:
       certificates:
        ...
       config:
          contact:
             email: test@test123.com
             firstName: 'John '
             lastName: Snow
          credentials:
             secretName:   ....
          url: >-
               https://servicename.projectname.svc:8443
  9. Save the change.
The changes can be seen on the Behavior Analytics Services page under Configurations in the IBM Maximo Application Suite administration menu.

 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000hAeeAAE","label":"Maximo Application Suite->Core"},{"code":"a8m3p000000GoLBAA0","label":"Maximo Application Suite->Installation"}],"ARM Case Number":"TS005829112","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.4.0"}]

Document Information

Modified date:
03 September 2021

UID

ibm16461905