IBM Support

Maximo Anywhere - Cannot issue and return items

Troubleshooting


Problem

Receive error: "BMXAA0029E - You are not authorized to perform this action for this record. Contact your system administrator to request changes to your authorization."

Symptom

STEPS:

1 Go to Users app

Create a user

Enter a password

Enter a default insert site

Go to Groups tab

Add ANYWHERE_ISSUES_RETURNS security group

2 Go to Security Groups application and create a group

Go to Sites tab, enter a site

Go to Applications tab

Filter for Inventory application

Grant Read and Save access

Grant Add/Modify Reservations option

Grant Current Balance option

3 Filter for Inventory Usage application

Grant New Inventory Usage, Read, Save Transaction access

Grant the following signature options:

  • Issue and Return
  • New Inventory Usage options
  • Select Items
  • Select Items for Return
  • Select Reserved Items
  • Change status to Complete

Save the record

Filter for Work Order Tracking application

Grant read only access

Go to Storerooms tab

Enter a site and storeroom

Go to Labor tab

Select Authorize Group for their own labor checkbox

Save the record

4 Log out of Maximo (Desktop)

5 Log in to Maximo Issues Returns application on a mobile device

Site is populated by default

Enter a storeroom

Click Issue Additional Items button

Enter an item

Click Search

Populate Issue To field

Enter a work order

Enter issue quantity

Click Complete

RESULTS: Receive error: "BMXAA0029E - You are not authorized to perform this action for this record. Contact your system administrator to request changes to your authorization."

Cause

Missing privilege required for Maximo Anywhere Issues and Return application

Diagnosing The Problem

select * from invuse  where ((invuseid = 64)) and (exists ( select siteid from siteauth a,groupuser b  where a.groupname=b.groupname  and b.userid =  'MAY'  and a.siteid = invuse.siteid))



Processing failed for OSLCINVUSE. The object structure is 1. The primary object is INVUSE. The key is null.BMXAA0029E - You are not authorized to perform this action for this record. Contact your system administrator to request changes to your authorization.

Run the query with a SQL tool

Output:

Invusenum = 1014

Go to Inventory Usage application, there is an entry shows an entry for ENTERED status

image-20230226145214-1

But no entry for COMPLETE status

Resolving The Problem

Go to Issue security group, Applications tab

Filter for Inventory Usage application

Grant access to the following signature options:

Add/Modify reservations (issue reserved items)

Change Status (change inventory usage record to complete)

Change status to Cancelled (in case there is an error, user can click Rollback Error to rollback the transaction)

Create Remaining Usage Lines (insert into inventory usage lines)

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSPJLC","label":"Maximo Anywhere"},"ARM Category":[{"code":"a8m3p000000Go1VAAS","label":"Mobility-\u003EApplication"}],"ARM Case Number":"TS012249811","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6.4"}]

Document Information

Modified date:
02 March 2023

UID

ibm16958430