IBM Support

MASUSERSYNC fails to sync user as it already exists

Troubleshooting


Problem

When running the Maximo Manage crontask MASUSERSYNC to insert or update users to Maximo Application Suite, the sync does not complete.

Symptom

Reviewing the Manage pod logs where the crontask ran, this error can be seen:
[ERROR] [MXServer] [CID-CRON-530479] BMXLM0504E - HTTP Response Code 409: {"exception":{"id":"AIUI1002E","properties":["user","maxadmin"]},"message":"AIUI1002E: Unable to create user/maxadmin.  It already exists"}
psdi.util.MXApplicationException: BMXLM0504E - HTTP Response Code 409: {"exception":{"id":"AIUI1002E","properties":["user","maxadmin"]},"message":"AIUI1002E: Unable to create user/maxadmin.  It already exists"}
	at psdi.iface.mic.MicService.sendData(MicService.java:2051) ~[businessobjects.jar:?]
	at psdi.iface.mic.MicService.syncUserData(MicService.java:1762) ~[businessobjects.jar:?]
	at psdi.iface.mic.MicService.syncUsersToMAS(MicService.java:1695) ~[businessobjects.jar:?]
	at psdi.server.MASUserSyncCronTask.cronAction(MASUserSyncCronTask.java:140) [businessobjects.jar:?]
	at psdi.server.CronTaskManager.callCronMethod(CronTaskManager.java:2594) [businessobjects.jar:?]
	at psdi.server.CronTaskManager.access$1100(CronTaskManager.java:107) [businessobjects.jar:?]
	at psdi.server.CronTaskManager$CronThread.run(CronTaskManager.java:3513) [businessobjects.jar:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:839) [?:?]
Within the Maximo Application Suite Core namespace, the internalapi pod logs can also be reviewed:
managers.users DEBUG    Upserting user: maxadmin
managers.users ERROR Unable to create user/maxadmin It already exists
Traceback (most recent call last):
File "/opt/ibm/internalapi/managers/users.py", line 576, in upsertBulkUsers
raise exceptions.ConflictError("user", email['value'])
exceptions.ConflictError: AIUI1002E: Unable to create user/maxadmin. It already exists

Cause

MASUSERSYNC is designed with upserting in mind. If the user exists in Maximo Application Suite, it should update the user rather than attempt an insert. The reason this specific error occurs is explained within this exception:
File "/opt/ibm/internalapi/managers/users.py", line 576, in upsertBulkUsers
raise exceptions.ConflictError("user", email['value'])
The failure is due to the email address, rather than the userid. The upsertBulkUsers API is erroneously case-sensitive, so it treats the same email address with different capitalization as two separate email addresses. This means if you try to update a user with a camel case email address (maxAdmin@email.com), but the update uses a lowercase email address (maxdmin@email.com), the API attempts to perform an insert rather than an update.

Resolving The Problem

This is being treated as known issue DT242505 and will be fixed in a future Maximo Application Suite release.
Until this is resolved, you can review the users you are trying to sync via MASUSERSYNC by looking at their email records in Maximo Manage. Ensure the capitalization of these emails match the capitalization of their user record in Maximo Application Suite. Once the capitalization matches, MASUSERSYNC will now properly attempt to update rather than insert.

Document Location

Worldwide

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Document Information

Modified date:
17 October 2023

UID

ibm17046042