Troubleshooting
Problem
The MAS usersync fails to add or sync users.
Symptom
User sees error message in Maximo Application Suite.
Your updates were not saved due to a system timeout. Retry the action. If the issue persists, contact IBM Support. Maximo Application Suite Users application.
Cause
Reviewing the log you see an error message.
manage-usersyncagent usersync-agent-manage ERROR [redding] Got exception: [main redding] synched: status_code: 400 r.text Error 400: BMXAA4211E - Database error number -803 has occurred when operating on EMAIL : E-mail=REDDING@ibm.com. Report the error to the owner of the deployment.
Processing failed for MASPERUSER. The object structure is 1. The primary object is PERSON. The key is REDDING.BMXAA4211E - Database error number -803 has occurred when operating on EMAIL : E-mail=REDDING@ibm.com. Report the error to the owner of the deployment.
Diagnosing The Problem
Query the EMAIL table.
SELECT * FROM EMAIL where emailaddress ='REDDING@ibm.com'
If you see that the email exists, Maximo by rule doesn't allow duplicate email addresses so the process fails.
Resolving The Problem
Make sure that each user and person has a unique email address. The MAS Usersync process now runs correctly.
Document Location
Worldwide
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Document Information
Modified date:
27 July 2023
UID
ibm17015193