Troubleshooting
Problem
After a change was applied to IBM Maximo Application Suite (MAS) or IBM Maximo Manage, the custom resources are not reconciled.
For example after you enable manual certificates in the Suite custom resource, you set manualCertMgmt: true in the spec section, you see that the status section still shows manualCertMgmt: false
Cause
An error occured in the operator that is preventing the reconciliation to succeed
Diagnosing The Problem
In version 8.10 and before, the suite custom resource is reconciled by the mas operator, in version 8.11, it is reconciled by the entitymgr-suite operator.
Check the logs for the operator for errors.
for example:
{"level":"error","ts":"2024-02-01T08:51:35Z","logger":"runner","msg":"\u001b[0;34mansible-playbook [core 2.15.2]\u001b[0m\r\n\u001b[0;34m config file = /etc/ansible/ansible.cfg\u001b[0m\r\n\u001b[0;34m configured module search path = ['/opt/ansible/library']\u001b[0m\r\n\u001b[0;34m ansible python module location = /usr/local/lib/python3.9/site-packages/ansible\u001b[0m\r\n\u001b[0;34m ansible collection location = /opt/ansible/.ansible/collections:/usr/share/ansible/collections\u001b[0m\r\n\u001b[0;34m executable location = /usr/local/bin/ansible-playbook\u001b[0m\r\n\u001b[0;34m python version = 3.9.16 (main, Sep 22 2023, 17:57:55) [GCC 8.5.0 20210514 (Red Hat 8.5.0-18)] (/usr/bin/python3)\u001b[0m\r\n\u001b[0;34m jinja version = 3.1.2\u001b[0m\r\n\u001b[0;34m libyaml = True\u001b[0m\r\n\u001b[0;34mUsing /etc/ansible/ansible.cfg as config file\u001b[0m\r\n\u001b[0;31mERROR! Unexpected Exception, this is probably a bug: [Errno 28] No space left on device\u001b[0m\r\nto see the full traceback, use -vvv\r\n","job":"4687123108924943814","name":"masinstanceid","namespace":"mas-masinstanceid-core","error":"exit status 250","stacktrace":"github.com/operator-framework/operator-sdk/internal/ansible/runner.(*runner).Run.func1\n\t/workspace/internal/ansible/runner/runner.go:269"}
For a list of the MAS and Manage pods and their function, refer to
https://www.ibm.com/docs/en/mas-cd/continuous-delivery?topic=reference-maximo-application-suite-pod-details
Resolving The Problem
Restart the pod (delete the pod so it will be recreated).
This error may affect other operators, you can collect the MAS must gather using the CLI and search all logs for the same error and restart the pods where this error occurred.
Document Location
Worldwide
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Document Information
Modified date:
13 February 2024
UID
ibm17116833