Troubleshooting
Problem
When using the []managesdk.sh[
] command to upgrade an IBM WebSphere Application Server for z/OS Version 8.5 profile from Java 1.6 to Java 1.7, the output might indicate that the task completes successfully but the log for a subsequent application server start might indicate that the node still starts using SDK 6.0.
Cause
This problem occurs because the managesdk.sh
command does not update the z/OS was.env
file when it updates the SDK configuration settings of the node using the AdminTask.setNodeDefaultSDK() call.
Resolving The Problem
To resolve this problem, perform the following task after running the managesdk.sh command:
./wsadmin.sh -lang jython -user user_name -password password
wsadmin>AdminTask.setNodeDefaultSDK('-nodeName node_name -sdkName sdk_name')
wsadmin>AdminConfig.save()
Note: Both the managesdk.sh command and the setNodeDefaultSDK() task must use the same value for the -sdkName parameter.
Note: You can optionally install Version 8.5.0.1 to resolve this issue.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21595261