IBM Support

Login successfully with "Internal Server Error"

Troubleshooting


Problem

In Maximo Assist 8.4.0, users can log in successfully although an “Internal Server Error” error occurs.

Symptom

If you check any one of the Assist studio/technician/admin-console pod logs that are in Assist name space mas-{{instanceId}-assist, for example for the {{instanceId}}-ema-studio pods, the following types of errors exist: 

UnhandledPromiseRejectionWarning: JwksError:

Unknown authentication strategy "jwtStrategy"

Cause

The pods restart for Assist components and the pods connect to the MAS coreidp service to get the jwks keys, but a networking intermittent issue occurs and the unhandled promise exception is not caught and causes the following error: Unknown authentication strategy “jwtStrategy”

Getting the jwks key during the pod startup involves a one-time connection. After the pod gets the jwks key and then start, it will not connect to coreidp again to get the jwks key.

Resolving The Problem

Log in to the Red Hat OpenShift Container Platform cluster and run the following command to reboot the related (studio,technician,admin-console) pods in Assist namespace (project).
oc get pods -n mas-{{instanceId}-assist | grep -Ei ‘studio|technician|admin-console’ |awk ‘{print $1}’ |xargs oc -n mas-{{instanceId}-assist delete pods

After those pods are restarted, you can log in to Assist. You can check the pods status is running the following command:

oc get pods -n mas-{{instanceId}-assist | grep -Ei ‘studio|technician|admin-console’

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m3p000000F83HAAS","label":"Maximo Application Suite->MAS Applications->Assist"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.7.0"}]

Document Information

Modified date:
20 July 2022

UID

ibm16605273