Troubleshooting
Problem
Attempts to login to the Management Console of IBM Rational Build Forge results in the error "License Error: Build Forge license key is corrupt or missing".
Symptom
After logging into the Management Console in Rational Build Forge the following message can be displayed:
"License Error: Build Forge license key is corrupt or missing"
- This is displayed in red in the top left hand corner of the window.
- It will not be possible to perform Build Forge operations.
Cause
The Build Forge Engine is not able to acquire the necessary licenses.
Diagnosing The Problem
Check the following items to ensure that Build Forge is able to get the licenses it needs:
- Check to see that the Administration > System > License Server setting is pointing to the correct License Server
- Did the IP address change?
- Did the name change?
- Check to see if you have both the Server as well as the User licenses installed
Resolving The Problem
Resolve the specific license key issue in your environment to restore Build Forge operations:
- Change the name of the license server host to the correct name
- Install either the Server or User license as needed
[{"Product":{"code":"SSB2MV","label":"Rational Build Forge"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Engine: License Keys","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF035","label":"z\/OS"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"},{"code":"PF016","label":"Linux"},{"code":"PF010","label":"HP-UX"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
09 October 2018
UID
swg21423973