Troubleshooting
Problem
Attempts to login to IBM Rational DOORS results in the error "Innvaild (pre-V8) DOORSHOME"
Symptom
You can not start the DOORS client.
- Attempts to login result in a sequence of DOORS report windows with error messages related to the client program files installation.The full error message is as follows:
"Invaild (pre-V8) DOORSHOME for this DOORS executable"
image
- When you Click OK to close the DOORS report a message window appears with an undeclared variable error. The full error message is as follows:
"-E DXL: <layout/actual/common_globals.inc:1> undeclared variable (R) Included from:
<c:\Program Files\IBM\Rational\DOORS9.3/lib/dxl/init.dxl:46>
<Line:1>"
image
- When you Click OK to close the DOORS report a message window appears with a badly formed token error. The full error message is as follows:
"-E DXL: <layout/actual/common_globals.inc:1> badly formed token (Ctrl-@) Included from:
<c:\Program Files\IBM\Rational\DOORS9.3/lib/dxl/init.dxl:46>
<Line:1>"
image
- When you Click OK the message window closes.
Cause
Your DOORS client installation has been corrupted and you can not log in to the database server.
Resolving The Problem
- Log into the machine as local administrator
- Remove the DOORS client software using Windows add/remove programs
- Reinstall the DOORS client
[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5.1.1;9.5.1;9.5.0.1;9.5;9.4.0.1;9.4;9.3.0.7;9.3.0.6;9.3.0.5;9.3.0.4;9.3.0.3;9.3.0.2;9.3.0.1;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
01 May 2020
UID
swg21649129