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Logging onto Rational DOORS results in "RDS is not available" error

Troubleshooting


Problem

Attempts to log in to IBM Rational DOORS configured with IBM Rational Directory Server (RDS) to use corporate LDAP using Microsoft Active Directory (AD) results in the error message "RDS is not available".

Symptom

You cannot log onto Rational DOORS.

Only Administrator can log in without errors.

Cause

When RDS is configured to work with AD, the authentication is as follows:

DOORS > RDS > AD, then from DOORS > AD.

As a result, if tdsadmin type the hostname of AD server as the hostname for LDAP server and your computer has no servername to IP address mapping, the connect in most of the conditions will fail.

Resolving The Problem

Add a line in the hosts file under C:\Windows\System32\drivers\etc to map your IP address to the host name.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Directory Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.2;9.3;9.4;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21653477