IBM Support

LMI を介して「ポリシーの管理」(Policy Administration)を使用しようとした場合に、HPDJA0116E Cannot contact server. (0x307a8074) が表示される。

Troubleshooting


Problem

IBM Security Verify Access(ISVA)アプライアンスで、ローカル管理インターフェース(LMI)を介して「ポリシーの管理」ツールを使おうとすると、「HPDJA0116E Cannot contact server. (0x307a8074)」というエラーが表示され、ログインに失敗します。
ただし、アプライアンスのコマンド・ライン・インターフェイス(CLI)を介した pdadmin のログインと使用は正常に機能しています。

Cause

アプライアンスは Policy Server をホストしており、ランタイム・コンポーネントが構成された初期構築後にホスト名が変更されていました。
pd.conf 構成ファイルは、変更後の新しいホスト名を反映するように更新されましたが、「ポリシーの管理」が接続先の Policy Server のホスト名を決定するために使用する「/usr/lib/jvm/ibm-jre/PolicyDirector/PD.properties」ファイルを更新する方法はありません。

Diagnosing The Problem

アプライアンスからサポート・ファイルを収集し、現在の Policy Server のホスト名(または IP アドレス)と一致している必要がある以下の設定エントリを確認して比較します。
  • /usr/lib/jvm/ibm-jre/PolicyDirector/PD.properties ファイル内の「appsvr-plcysvrs =」
  • /var/PolicyDirector/etc/pd.conf ファイル内の「master-host =」
エントリが一致しない場合は、この技術文書で説明されている問題が発生しています。

Resolving The Problem

IBM サポートに連絡して、フィックスパック「update_pd_properties.fixpack」を要求してください。
このフィックスパックは、アプライアンスにインストールされると、Policy Server のホスト名とポート設定を pd.conf から PD.properties ファイルに一度だけ同期して、不一致を修正します。

Related Information

Document Location

Worldwide

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Document Information

Modified date:
27 December 2022

UID

ibm16851847