Troubleshooting
Problem
This technote explains how to resolve an Automation Error error, that can occur when using IBM Rational RequisitePro.
Symptom
When a user or multiple users are trying to log into a RequisitePro project using LDAP authentication, they receive the following error:
Automation Error
The specified module could not be found
However, they do not receive this error when logging into the project using RequisitePro authentication.
Cause
This may be caused by the installation of RequisitePro on the user's workstation and the module that LDAP calls upon. The module may not be registered or installed properly.
Resolving The Problem
Below are two suggestions for trying to resolve the above error.
Re-register all DLLs in the \Rational\RequisitePro\bin\ directory:
- Close RequisitePro
- Open a command prompt and change directory to C:\Program Files\Rational\RequisitePro\bin (
cd "c:\program files\rational\requisitepro\bin\")
- Type in (or copy/paste):
for %1 in (*.dll) do regsvr32 -s %1and press Enter.
- After it has completed re-registering all of the DLLs, it will return to the command prompt.
- Now try to log into the project with LDAP authentication.
- If this did not resolve the issue, follow the steps below to perform a clean uninstallation
Perform a clean uninstallation of RequisitePro
- Follow this technote on how to perform a clean uninstallation: 1189855: Clean uninstall of RequisitePro version 2003.06 and 7.x
Note: If you are using RequisitePro 7.1, you will have to remove RequisitePro through Installation Manager and not through Add/Remove programs.
- After the uninstallation is completed, re-install RequisitePro
- Try to log into the project again using LDAP authentication
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21396369