IBM Support

Launching ikeyman fails on Windows if there is a space in the WebSphere install Path

Troubleshooting


Problem

Attempting to start ikeyman.bat fails with no error message.

Symptom

Cause

This has been identified as a product defect under APAR PI23164

Environment

Windows

Diagnosing The Problem

Resolving The Problem

Manually edit ikeyman_old.bat.

Change,

if "%JAVA_HOME%"=="%JAVA_JRE%" (
set EXT=%JAVA_HOME%\lib\ext
) else (
set EXT=%JAVA_HOME%\jre\lib\ext
)

to (notice additional double quotes)

if "%JAVA_HOME%"=="%JAVA_JRE%" (
set "EXT=%JAVA_HOME%\lib\ext"
) else (
set "EXT=%JAVA_HOME%\jre\lib\ext"
)

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Security","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;8.5;8.5.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21680924