IBM Support

Known issues with IBM Spectrum Protect Operations Center Version 8.1.10

Question & Answer


Question

What are the known issues with IBM Spectrum Protect™ Operations Center Version 8.1.10?

Answer

The following issues have been identified in version 8.1.10 of the Operations Center:

Log-in and general issues

Storage Pools

Retention Rules

Message: ANR3218E UPDATE ADMIN: Administrator IBM-OC-server_name is a managed object and cannot be updated

Symptom

The error message ANR3218E is displayed. This error might be displayed when you try to connect a spoke server to the hub server, or when you try to update passwords on spoke servers.

Cause

The Operations Center runs independently of enterprise configuration, and is unable to update user IDs that are managed by the configuration manager. An administrator ID that the Operations Center creates and maintains on spoke servers was unintentionally placed under the control of the configuration manager.

When you try to connect a spoke server to the hub, the Operations Center attempts to register the monitoring administrator ID, IBM-OC-server_name, on the new spoke server. This same monitoring administrator ID with the same password is registered on the hub server and on all spoke servers. Periodically, the Operations Center automatically updates the monitoring administrator ID password on the hub and spoke servers. You typically do not need to use or manage this password. If the password update was not successful, and the Operation Center detects that the passwords on one or more spokes are not current, it prompts you to have it attempt the password update again.

If the error message ANR321E is displayed when you try to connect a spoke server or update a spoke server's monitoring administrator ID password, it might be because the monitoring administrator ID was inadvertently placed under the configuration manager's control. You might unintentionally place the monitoring administrator ID under the control of the configuration manager when you issue the DEFINE PROFASSOCIATION command. If you use a wildcard character in the DEFINE PROFASSOCIATION command to identify which administrators are associated with the configuration profile, you might unintentionally match the monitoring administrator ID. For example, you might associate all administrator IDs with the configuration profile by specifying admins=* in the DEFINE PROFASSOCIATION command.

Solution

Do not specify admins=* in the DEFINE PROFASSOCIATION command when you associate administrator IDs with the configuration profile. Instead, list all administrator IDs, excluding the monitoring administrator ID, in the command. For example, admins=admin1,admin2,admin3,admin4. Make sure to update the list when administrator IDs are added to or removed from the hub server.

Tip: You can use an enterprise configuration to maintain the monitoring administrator ID on spoke servers, but only if you designate the configuration manager server as the Operations Center hub server. For more information about grouping hub and spoke servers in an enterprise configuration, see
https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.10/srv.install/c_oc_inst_reqs_tips_for_hub_spoke.html

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Usage and configuration information is not shown for a container storage pool

Symptom

To display detailed information about a container storage pool, you select the storage pool on the Storage Pools page and click Details. On the Summary tab of the Details notebook, no information is shown in the Usage and Configuration area. In the Usage and Configuration area, the status message Loading... is displayed. Eventually, the operation times out and the Usage and Configuration area displays the message Cannot retrieve data. The following error is displayed in a separate window:

Error occurred while making the Web server request: Timeout exceeded

Cause

For some container storage pools, the Operations Center is unable to load usage and configuration information within a defined timeout window. This can occur if there are many containers in the storage pools that are defined on the server. This condition is most likely when there are cloud-container storage pools defined on the server.

Solution

Although the usage and configuration information is not available on the Summary tab of the Details notebook, you can view some of the same information from other tabs of the Details notebook. On the Properties tab of the Details notebook, you can view the following information for a storage pool:

  • Capacity and utilization measurements
  • The space savings that were realized by compression and deduplication
  • The overflow pool name
  • The protection pool name
  • The name of the tiering storage rule

On the Directories tab of the Details notebook, you can view the file system directories that are associated with the container storage pool. For directory-container pools, the directories define the storage pool size. For cloud-container pools, the directories define the size of a disk cache that is used to optimize data transfer to the cloud.

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Clients that were added to a retention rule by using the command-line interface are not shown as members of the rule in the Operations Center

Symptom

You created or edited a retention rule by using the DEFINE RETRULE or UPDATE RETRULE command. On the command, you identified clients by using one of the following methods:

  • You used the node_name parameter and specified a wildcard pattern.
  • You used the node_group_name parameter to specify a node group.
     

When you view details of the retention rule in the Operations Center, the clients that you added by using the command-line interface are not shown.

Cause

The Operations Center does not support the following types of clients and client specifications:

  • Name patterns for node names. You cannot specify name patterns for node names in the Operations Center. By using the command-line interface, you can specify node name patterns, but these specifications are not shown in the Operations Center.
  • Node groups. You cannot specify node groups in the Operations Center. By using the command-line interface, you can specify node groups, but these specifications are not shown in the Operations Center.

Solution

Understand that node patterns and node groups are not supported or shown in the Operations Center.

Use the QUERY RETRULE command with the format=detailed parameter to display the clients that are associated with a rule.

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You cannot create a retention rule that specifies clients that are configured to receive replicated data

Symptom

You are creating or updating a retention rule. The rule specifies a retention storage pool, which enables retention-to-tape. The rule also includes at least one client that is registered to a target replication server and is configured to receive replicated data. After you click Create or Update to complete the action, the Operations Center displays a message indicating that there were errors. If you click Show details, the following error is shown:


ANR4165E command: The command cannot be issued for node node name
because the specified node is a replica node and cannot be used to
make retention set copies.

Cause

At least one client is configured to receive replicated data from a client on another server. When retention-to-tape is configured in V8.1.10, the retention set cannot include clients that are replicas of clients on another server. This is a restriction only for the copy-to-tape operation. Retention rules that are configured for in-place retention are not restricted from including replica clients.

Tip: Replica clients are not shown on the Clients page in the Operations Center. However, if a client that is listed on the Clients page is replicated to a target server, the Target Server column identifies the target server. You can also view the clients that are defined to target replication servers by issuing the QUERY NODE command. Look for the value Receive in the Replication Mode field of the output.

Solution

If a retention rule that is configured to copy retention sets to a retention storage pool, do not specify clients that are configured to receive data during replication. However, on a source replication server, you can specify clients that are configured to send data during replication.

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Document Information

Modified date:
09 September 2020

UID

ibm16213258